HP envy x360 Won't Boot Ubuntu

I have been trying to load ubuntu on to my newly purchased HP envy x360 and I’m immediately running in to an issue with installing off of USB. Doesn’t matter whether I hit “try ubuntu” or “install ubuntu” I still get this same issue. I have the 15" AMD ryzen 2500U model of the x360. I tried googling around and found a couple threads talking about the issue but no solution was listed.
Please help me dear wizards of linux!

What version of Ubuntu?

Ahh yeah that’s an important detail. I had just downloaded it off of the website. It’s ubuntu 18.04.1 LTS

I updated your title slightly.

Taking a total guess I’d imagine it’s kernel related, have you tried any other distros like Fedora (up to date ISO here) just to see if they boot the live environment?

I have not yet. I’ll try that and update shortly.

Alright, I tried the F28-KDE-x86_64-20180722-Live.torrent download, used rufus 3.1 to write it to a flash drive and then I got these errors, it at least did something but still is not working.

Did you turn off Secure Boot? Recent Ubuntu Kernels are unsigned, and potentially Fedora Kernels too.

Yeah I had to do that in order for it to even try to boot off the USB.

In the Linux native gaming video Wendell said that the newest kernel version runs the and graphics better. Would it be worth taking the SSD out of my laptop and loading Linux on to it through my desktop (which I know works with Linux) and then updating the kernel before plugging it back in?

Try booting with amdgpu’s power management disabled, see if that lets you progress. You might be affected by a known bug.

As you boot the LiveCD, you’ll be presented with the GRUB menu. Visual Hint
Press ‘e’ on the first menu option

Add the following line to the boot parameters:


Press ctrl+x to boot. Visual hint

Tried putting that line in and still get the same issue. still using ubuntu 18.04.1

Other kernel parameters:

nomodeset - disables amdgpu and will help you do initial install/booting. You will want to update/run the latest possible kernel as there are ongoing Raven Ridge fixes w/ 4.17, 4.18, and beyond…

idle=nomwait - your next issue will probably be intermittent lockups - this is supposed to help. On my desktop 2400G, disabling global C-states seemed to do the trick, but for a laptop that would be pretty terrible. You can read through the thread for other suggestions (disabling SMT, setting the CPU governor, etc)

The padoka ppa seems to have cutting edge packages, but I haven’t tried them.

I had issues trying to install 18.04 on my 2400G - rather than fight it too much, I just ended up installing Arch. Maybe give the 2018.08.01 installer a try - it’s running on 4.17.11 and pretty much the cutting edge (its linux-mainline is 4.18rc7 and its linux-firmware was last updated 2018-07-30).