HP/Agilent/Keysight 54285A - Fixup/Build Log

I have two of these 500MHz scopes, both with dead hdds, cmos battery modules and one exploded power supply.

https://forum.level1techs.com/t/post-what-new-thing-you-acquired-recently/149881/10434

I have taken photos (uploading later) of all the steps and managed to remove the K5 motherboard without damaging anything that I noticed.

I have a couple of these in the mail plus two udma 7 cf cards. This will replace the dead 2.5" IDE hdds.
image
In order to reinstall the factory os, Agilent posted a guide for all the different subversions of the scope, I happen to have two of the oldest scopes so I’ll be stuck with earlier software.

If the VIN number is 015 or does not exist:
Your scope is among the oldest Infiniium units. When your scope shipped from the factory,
it did not have the LS-120 (120 MB) floppy drive. … Some customers have been successful performing system recoveries with external CDROM drives from companies such as MicroSolutions. … If you can successfully get to this point, you should be able to perform a recovery with a special A.03.50 recovery CD. You may download the CD image at the location given below or contact Agilent technical support for a copy of this CD. …
A.03.50 Recovery CD:
ftp://ftp.agilent.com/pub/callpub1/ddt/scope/548xx/Upg_Rec/3_5/3_5_rec.iso

As luck would have it, I can’t find that file on that ftp site. (ok I didn’t search every directory recursively, but I searched the first half then found another source.

A handy member of the eevblog forum went through lots of what I’ll probably end up doing here. They also happened to save and post and still be hosting!! the files I need for my scopes. When I get the rtc module swopped, below, I’ll toss that image onto a cdrom and toss it onto it’s new ‘ssd’.

The cmos battery rtc module thing is an old version of these. It’s a parallel interface battery backed calendar clock doohickey instead of just a simple coin cell holder. There is an option that exposes the coin cell, however it is double the cost and the sealed unit will likely outlive the rest of the components so i don’t care if the new battery is only good for 15 years. If the rest of the hardware manages to live 15 years … well I’ll give it away or something and find something running a cpu from this century lol.

One of the power supplies (nx300-6003) mains filtering has exploded. I don’t know what caused it but I have ordered these capacitors to replace the two exploded caps I could see. There might be parts under the board too but I have yet to tear it down to that level. There is considerable charring around the power socket where these caps are located. Image stolen from here. The two white rectangles in this image are fairly blackened in one of my units. Again photos will be posted of my actual hardware eventually.

I should have all the parts above in by the end of week 42 2021. I am attending a wedding that weekend but will post an update when I get around to playing with this again.

Oh I nearly forgot, I ran to my parents place today where I store my extra crap and picked up a bunch of old pc stuff I played with growing up (Im 23) tossed in an authentic w98 start floppy disk and the K5 unit booted into that limited dos thing just fine. I forgot most of my dos commands but was able to change disks out and eventually got to the install screen of doom 1.9 … of course I had no hdd I could install it on, but it was a neat way to find and test a piece of software to image floppies with (diskwrite, updated in 2001).

1 Like

It works now thanks for coming to my build log.







Ok Here’s what happened.

1 Like

I hadn’t done much with it since the update but the new cable arrived. Passed all the cals first try now. Next I’ll look into that toasted psu.

1 Like

Been a bit busy with holiday things but just got some new to me sd ram. The scope now has 112MB of ram after a ramdrive was created!









And now I’m able to upgrade the software to a new version (4.3 vs stock 3.5) with more web tools!



I haven’t looked into the other psu yet, I need to buy more cd-r disks to keep transferring software to this guy …

There is a winxp version I will look into at some point too. USB support would be nice to have. Actually I’ll go try my pci usb card and report back.

Old Logitech wireless keyboard/mouse thing now works over usb!!! no longer will I be bound by a cable

e:



Found a couple things in the normally hidden system tray. Im sure they are secure and safe to plug into the internet /s


e2:
This guy’s usb drive driver appears to work for me. Got a 4gig fat32 drive to appear! That’ll make moving files around much easier.

1 Like