Return to Level1Techs.com

How To Use RDNA2 on Fedora 33

Hey guys,

since I’m a happy owner of a shiny new RX6800 I wanted to share my process on getting this brand new card to run on the latest Fedora!

I wasn’t able to use it with the 5.9.8 kernel that comes with the latest fedora, so we need to get the latest rawhide kernel. Since we don’t want to waste our time compiling the kernel but rather just game, we are going to install the fedora rawhide kernel.

Just as Sidenote, if you have CSM disabled and are facing failed boot attempts (or in other words monitor going to sleep and never turning back on), turn CSM on :wink:

Step 1

Skip this step if you haven’t got the gpu installed yet. Since 5.9 already added support for sienna cichild we need to boot with nomodeset, so that the amdgpu kernel driver doesn’t take control over the card and messes things up.

We do this by hitting e at the time we see grub. Then use the arrow keys to remove the quiet flag and replace it with nomodeset. Having done that boot your system with Ctrl + x.

Step 2

Download all the needed rpms for the 5.10RC kernel on the following page that beeing kernel-{,core,headers,headers-extra,headers-internal}:

https://download-ib01.fedoraproject.org/pub/fedora/linux/development/rawhide/Everything/x86_64/os/Packages/k/

As @Conan_Kudo pointed out the linux-firmware package is now up to date, so just making sure to run sudo dnf -y upgrade linux-firmware prior to installing the kernel.

Step 3
Now let’s install the kernel:

sudo dnf -y ./Downloads/kernel-*.rpm
sudo lsinitrd /boot/initramfs-5.10* | grep sienna_cichlid

If you see the following output, you’re set:

Now wait a couple minutes. Nice, we’re now set up to boot Fedora with our shiny new GPU! One thing to keep in mind tho is that you have to manually upgrade the kernel, make sure that the 5.10 kernel doesn’t get removed and you boot into the right one!

Step 4

This step might or might not be necessary. If you booted with a different gpu without nomodset before you can skip this and go on playing games on your pc :wink:

For some reason when installing the kernel with nomodeset booted the grub entry will set that for the new entry as well. (/etc/default/grub is unaffected) To change this run the following command replacing micro with your favourite editor like nano:

sudo micro /boot/loader/entries/$( sudo ls /boot/loader/entries/ | grep '5.10.0' )

Now highlight nomodeset and replace with quiet.

Now reboot and enjoy! :wink:

EDIT: I didn’t try it yet but instead of installing the kernel from rawhide one could try to install the fedora 34 version, which is also the 5.10RC4 . sudo dnf -y install --releasever=34 kernel-{,core,headers,headers-extra,headers-internal}

3 Likes

I’ve been on fedora 32 since release after being a debian snob for years and I really love it. About to dump win10 on my laptop for 33.

1 Like

The firmware is now available as an update in Fedora 33:

$ sudo dnf upgrade linux-firmware
4 Likes

@wendell sorry to bother you, but do you also have “failed boots” on fedora? My system seems to only boot 1 out of 10, all the other times the monitor just goes to sleep and never wakes up again… I have absolutely no idea what causes that…

Can’t say that I do. Sometimes it seems like the system doesn’t actually do a full reboot through bios though, which is annoying…

Weird, for me it’s really annoying since I have to try to boot the system many times to even get to the luks screen… Weird that you don’t seem to suffer from that, but Jason and I seem to be… I’ll try a new arch install later, maybe that’ll help…

Thats what it looks like: https://www.youtube.com/watch?v=Hg_rg0cTJMU

Sorry to have bothered you wendell, I figured it out! Enabling CSM did the trick! No idea why that would be the cause as Windows does boot fine with it and the same system with a RX5700 did as well on Fedora. Anyhwo I’m happy now ^^

1 Like

Ah yes with and without csm on these cards there may be some bugs. I had disabled csm completely on my threadripper machine to ensure pcie consistency

1 Like

Hi, I’ve got my 6800 running similarly to this guide, but the performance seems pretty poor.

[glmark2]https:// hastebin . com/xajewozato.yaml

It doesn’t seem to show up in lspci -nnk as a 6800 and I noticed in dmesg it initializes it with this
[drm] Initialized amdgpu 3.40.0 20150101 for 0000:0a:00.0 on minor 0
Which seems off to me since it’s from 2015.

I just upgraded my whole distro to rawhide, but got the kernel from the no-debug repo. Had to delete my xorg.conf to login.

Could you guys show me what yours looks like in glmark2 and lspci -nnk? I think it’s loading the wrong DRM or something