How to flash the BIOS on Asus Z690 Prime P if the system won't POST?

Background:
I bought my Asus Z690 Prime P motherboard about a year ago when 12th gen Intel CPUs launched sort of by accident. Originally, I wanted to deploy the platform as a DDR5 platform, but then the availability of DDR5 DIMMs basically vanished/completely evaporated, so I never got around to deploying that motherboard. (I left the box unopened until now.)

Fast forward to now, I just bought my Intel Core i7-13700K, figuring that I can just plop it in, update the BIOS, and away we go.

…except, that the system won’t POST for me to be able to go into the BIOS to perform said update.

I think that this is a Catch 22 problem.

Hardware specs:
Intel Core i7-13700K
Asus Z690 Prime P (don’t know the original BIOS version from almost a year ago)
2x 16 GB DDR5-5600 G.Skill Flare X5 Series CL36
Noctua NH-D15
No discrete GPU
Intel 670p 2 TB PCIe 3.0 x4 NVMe SSD
Corsair CX750M 750 W PSU
Corsair Carbide case

So, my question is:
I need to update the BIOS so that it will be able to recognise the 13th gen CPUs.

But I don’t have a 12th gen CPU anymore (it was RMA’d back to Intel due to problems with the on-die memory controller throwing faults/inducing data corruption).

I think that the system isn’t POSTing because the BIOS doesn’t recognise the 13700K.

But I need the system to POST so that I would be able to go into the BIOS so that I would be able to flash/update said BIOS.

The Asus Z690 Prime P does NOT appear to support BIOS Flashback.

So, how do I flash the BIOS in this case where the system won’t POST?

I’ve taking out one of the sticks of RAM already to see if I can get the system to post with just one stick of RAM and still no cigar.

All of the research that I’ve done already online in regards to flashing the BIOS assumes that the system will POST so that you can go into the BIOS to perform said BIOS update, but that’s not the case here.

Any suggestions would be greatly appreciated.

Thank you.

So does this model have a flashback option ?

That would be a way to flash to the current even if no cpu was installed or detected.

I think crash free bios only works with already compatible hardware but maybe worth a shot

If you don’t have bios flashback available, most retail stores are happy enough to update the bios for you. Or you could just buy a cheap cpu like a celeron cpu and then sell it on ebay after you’re done.

I don’t think so.

I checked online and from the pictures, it looks like that there is supposed to be a USB port with a button for said BIOS flashback.

That option does not appear to be present on the Asus Z690 Prime P motherboard.

I tried that already.

So no cigar.

Yeah, I might have to take the system to Microcenter and either ask them for help with that and/or take my system in for “repair”.

I’ve been trying to get a hold of Asus support as well, but unfortunately, their chat hours are relatively limited, so I’ll have to try again.

But yeah, that’s a bit of a problem.

I could, in theory. Unfortunately, the closest Microcenter to where I live doesn’t have a LGA1700 Celeron available for sale. The cheapest processor that they have is the Core i5-12400 for $180.

So we’ll see, but yeah, this is a bit of a problem (just in general).

Well at least you have a somewhat close Micro Center unlike where I live :frowning:

I have the same board and cpu. They flashed it in the store for me. So far so good. The thing is that I have a hard time getting any good benchmark scores. Do you have the same problem?

Been trying to google, thats how I ended up here.
Found this article, its at least very similar hardware.

hardwaretimes. Com/intel-13th-gen-cpus-facing-issues-on-z690-boards-core-i7-13700kf-48-slower-than-the-12700k-on-the-asus-tug-z690/amp/

@alpha754293

How did you solve this issue?