Return to Level1Techs.com

How do you test ECC is working on Ryzen?

#1

System:
1950x Threadripper
Asus X399-E Gaming
Kingston 4x16GB DDR4-2400 CL17 ECC Unbuffered

I got everything telling me ECC is enabled:
dmesg | grep -i edac
(windows) wmic memphysical get memoryerrorcorrection
memtest86
datawidth 64 , totalwidth 128

But I can’t seem to see it in action. Apparently, we can overclock the RAM and then it should become unstable and cause errors.

When I overclocked, it would either:
A. POST and boot and run through the tests with 0 errors.
or
B. Not POST at all.

I lowered the timings from 18-17-17-17-39 all the way down to 12-12-12-12-21 @ 2400mhz and it was still not giving me any errors. Raised speed to 2933mhz @ CL17, still no errors.

Beyond those points, it just wouldn’t post.

I used 18.04 lubuntu and installed ‘stress’, ‘memtester’, and ‘edac-utils’. I disabled swap with ‘sudo swapoff -a’
With stress, I ran:
stress -c 32 -m 120 --vm-bytes 500M
With memtester, I ran:
sudo memtester 60G 5

Throughout the tests, edac reported no corrected or uncorrected errors. Normally, the closer you get to timings that don’t POST, the more unstable it gets, and therefor more errors. Boggling my mind.

0 Likes

#2

Feed it incorrect data and see if it corrects it for you?

/s

I have no idea if this will work for you because I’m too broke to afford ECC memory in the first place but I’m guessing it has some sort of benefit?

1 Like

#3

Yeah, I saw that, but it’s a bit outdated.

Looks like my motherboard doesn’t report it properly, so it’s just silently correcting errors.

0 Likes

#4

@ECCAddict Have you figured out how to validate ECC yet?

0 Likes

#5

Overclocked your ram more. Mine is stable at 2933 with timings around 15, and I have 8sticks. Just keep upping the speed. 3200 or higher with no additional voltage will likely start giving you problems

0 Likes