How do you set up your bootloader?

Hello again,

I been having some problems getting my bootloader set up correctly. I want to be shown the windows 8 bootloader and have the two options boot straight into the OS. Currently I have GRUB running where I either boot into ubuntu or into windows bootloader, which only detects my windows partition so takes extra time to boot.

I have tried using easyBCD but found myself getting boot errors (0x000000000098) so I had to repair BCD in CMD.

What bootloader are you using?

Ironically, along same lines does anyone know how to fix grub? I just moved to ubuntu 14.10 from 14.04 cause of the amd driver issue, and it killed my grub..... I cant even get to my windows partition.

What is your boot order in your BIOS?

It goes to grub properly, but since i upgraded it gives me an error. Another issue might be when it finishes installing it just goes to a black screen. Does not fully restart.

Yay, I was able to just force reinstall the kernel via usb again and it repaired it itself.

Your BCD might of been corrupted or overwritten, if you have your windows install disk you can go to repair, advanced, CMD and type in bootrec /rebuildbcd. It got me back my windows partition.

AMD did not kill your grub it killed your x server.. just run sudo apt-get remove fglrx* you will be fine.. as for the other guy.. stick with grub and you change the timeout to something small.... or you could unplug the HDD with windows on it leaving only linux and run sudo update-grub.. should only detect linux then in the bios you can select default boot HDD.. that will speed up your boot if it is that important

On your GRUB menu, does it boot straight into windows, or the bootloader?

1 Like

if it does not detect windows via OS probing then it will go straight into linux... but it will still give you a time out to select either your default or your advanced recovery linux options or different kernels

Bottom line is just change the delay time.. theres no real way to make it instant boot and skip grub

So how would I go about getting my windows bootloader to have linux on it. I can change the timeout to make it appear as if GRUB did not load and change default to my windows bootloader.

I am not experienced with that.. and I find the EasyBCD does not work with grub efi and uefi booting.. so if thats your case its not really possible to the extent of my knowledge

Actually thats the Boot failed code when you boot with UEFI mode enabled.. so I think that confrims what I am saying

So I can't boot both OSes through the windows bootloader and I can't skip GRUB loading the windows bootloader.

what do you mean grub loading the windows bootloader and on efi system you can modify the bootloader of Windows due to secure boot...

So GRUB loads up and I have the option to boot straight into Ubuntu or load the Windows boot manager. When I select Windows boot manager it loads, finds only my Windows partition and boot Windows. Also I have no idea how to modify the Windows bootloader, I have tried easyBCD but I always need to rebuild my BCD in order to get it working again.

like I said easybcd doesn't work with uefi so you can't really modify your Windows bootloader to boot Linux in efi modes.. you also can turn down the delay for the grub menu but it will always display Windows.. there isn't a way around it and it is a good thing it's there

My GRUB menu doesn't display windows, it only show me the boot manager for windows.

So when you boot up your PC, what does your GRUB menu look like.

opensuse 13.2
advanced options opensuse
Windows bootloader