Return to Level1Techs.com

How do you set up a Coolermaster X-Dock?

#1

     I have been trying for the past couple of days to set up the X-Dock on my CM Storm Trooper, but I have had no luck. At first I just tried powering of my computer, plugging in a 2.5 inch HD, and then powering it on, but nothing recognized that there was a drive in there, not even my BIOS. After further inspection I noticed that there is a SATA port and a Molex socket way up inside the case where the front panel is. (I thought that it just used the SATA cable that is coming out of the front panel along with the power cables that came with the case, but apparently that's just for the eSATA port on the front and the case fans.) I tried it again with both cables plugged in but still no luck. I also tried it by enabling AHCI on my BIOS, but now Windows 7 won't boot.

Does anyone know how to set up the X-Dock on the Cooler Master Storm Trooper or what my problem is?

P.S. My motherboard is the Gigabyte GA-990FXA-UD5 (If that helps at all)

1 Like

#2

is there a setting in your bios for hot swap for the sata port you are connecting to? enable it then plug the ssd in and reboot. should see it now

0 Likes

#3

It only shows IDE or AHCI

0 Likes

#4

i tried to pull up the MB manual nut it was Chinese not English as stated.

 

edit--never mind got it

0 Likes

#5

you might have to set the Onchip sata port from disable to enable ESP on the port you want in order to hot swap.

OnChip Sata port to ESP---------THEN SET THE PORT YOU WANT

look under integrated peripherals. look at page 45-46 of the online manual if you can not find it

 

0 Likes

#6

I've figured out how to enable hot swap, but Windows won't boot anymore from my main drive.

0 Likes

#7

What did you do? I told you  how to enable it for a single sata port

0 Likes

#8

OK, the reason that Windows wouldn't boot is because my BIOS would automatically switch the top boot priority to my external hard drive that I use to back up my main drive. So I switched the boot priority back and it Boots now, but the 2.5 inch hard drive I have in the X-Dock isn't being recognized.

0 Likes

#9

I know that I have to install a driver for AHCI on Windows now but I don't know how to. I downloaded the Marvell 9172 AHCI/RAID driver from here, do I have to extract it to somewhere?

0 Likes

#10

what version of windows? because win7-8 comes with the drives already. did you try to enable ESP for the port? i know on gigabyte boards you have to enable esp for hot swap.

you normally load the drives on install of OS but there is a way to hack them in post instal but like i said you should not have to.

 

p.s. i had a MB that changed like that on me and it drove me nuts trying to get it to save so i feel your pain

0 Likes

#11

I have Windows 7, but it still doesn't recognize the drive. Let me check if the drive is hot swap compatible.

0 Likes

#12

I don't think that this drive can run with ahci. I couldn't find it for sure anywhere, but it still isn't even recognized by my bios with ahci turned on.

0 Likes

#13

i would be really surprised if it did not support it. you can not see this drive under bios or disk management? I still stand by my statement about ESP. I had the MB right before this model and that is what I had to do. Even states it in the Mb manual but that is only for hot swap. Maybe the controller board in the hot swap bay needs this turned on though.

Wish you lived nearby. I now I could get this to work.

0 Likes

#14

I plug all kinds sata drives into my MB with no problems daily. This has to be an issue with the controller board in the case. I am not saying it is bad. That is why I have been leaning towards the ESP on the port in the bios.

If you unhook your other drives and connect this drive up to you main sata cable with power and reboot to bios, can you see the drive?

0 Likes

#15

I enabled ESP on the X-Dock's sata port but it still din't show up. I unplugged all of my other drives, and still no luck. I can get it to run in a normal configuration, but just not on the X-Dock, so it can't be the hard drive because i plugged it into one of the ports that is using ahci. I have also come the conclusion that it must be the front controller panel.

0 Likes

#16

must be. try writing the company for a replacement. sorry you could not get it. I tried to help. good luck

0 Likes

#17

I see it’s a 5 years old question, but anyway. I stumbled on the same problem today. I had exactly same question.
Have been searching on the Internet for solution… I never considered myself as a lamer until now. Why? Because it was as simple as 1, 2, 3…
Here we go: When you purchase CM Stormtrooper and arrange stuff inside the case I thought X-Dock was already connected…
Now, few years later, I wanted to use it, but it didn’t work.
Solution: Connect SATA-cable! It was hard to find it on the dock, but it’s only thing you need!
Don’t forget that power cable should be connected too.

0 Likes