How do I confirm the cause of an I/O issue?

I need a bit of a sanity check. I got a new work laptop at the beginning of 2021, a HP 840 G7 running W10 1909. I’ve been having a problem with it for several months where it does 1 of 3 things on fairly regular basis.

  1. If I let the computer lock, when I come back later to use it again it will not bring up the logonUI. Like I’ll press enter and just nothing will happen and the screen will go black again after a minute or so from inactivity, or LogonUI.exe will throw an error with the message “The instruction at [memory address] referenced memory at [other memory address]. The required data was not placed into memory because of an I/O error status of 0xc000000e.” The only way to sign back in is to hard reset the machine.

  2. If I let the computer lock it will restart on it’s own while I’m away. There’s no logs in the event log nor is there a memory dump.

  3. I will just blue screen while I’l using it, again nothing in the event log nor memory dump to read.

I just had my computer re-imaged, and they had trouble re-imaging it. It kept failing until the tech wrote 0s to the drive first and then it finally accepted the image. I take it home and with a fresh re-image that I haven’t loaded anything on to yet, I already experienced #1 and #3 again.

I’m thinking this is a storage hardware issue, bad NVMe drive. My reasoning is that 1) it’s throwing an IO error when it shows me an error. 2) It’s not writing out the memory dumps as per the usual for a blue screen (it is setup to dump the memory, I double checked). 3) The techs had issues re-imaging it. It seems to me there’s a storage device issue, but is there anything I’m overlooking? Does anyone know what exactly a 0xc000000e error status is?

Thanks in an advance if anyone has any clues.

it is likely you are correct. The symptoms are consistent with an ssd that has never been trimmed properly and is now failing or is otherwise dying. depending on the brand of the drive, you may be able to use smart utilities to see if the drive self-predicts failure. if so, just replace it, ulgh,

2 Likes

refers to boot config errors on the drive.
possible fixes.
boot off your repair image and select the cmd prompt.
and type:

bootrec /fixmbr
bootrec /fixboot
bootrec /ScanOs
bootrec /RebuildBcd

if windows boots open an elevated cmd and run

sfc /scannow
DISM /Online /Cleanup-Image /CheckHealth
DISM /Online /Cleanup-Image /ScanHealth
DISM /Online /Cleanup-Image /RestoreHealth

this will repair any software errors in the install that could have been created by bad writes.
in the same cmd
type :

fsutil behavior query DisableDeleteNotify

if you get a 0 it means trim is enabled. and there’s nothing left to do but hope its fixed.

if its disabled, type:

fsutil behavior set DisableDeleteNotify 0

to enable it. :slight_smile: and your done… hopefully.

btw if it was trim disabled you might want to. go into bios and run the bios’s nvme performance test if available.
it should tell you what % of the disk is still usable. if its new and showing a very low number, it needs replacing.

if that fails raw the drive and install a fresh.
why?
sadly the bsod error might be a result of drm installed on the boot partition by the manufacturer.

HP EliteBook 840 G7 Notebook PC Specifications | HP® Customer Support

look under software/security. a whole lot of crapware (including what looks like tpm keys, so you may need to turn off tpm in bios and clear the keys)

anyhoo. sorry about the edits. i shouldn’t post here when im tired :slight_smile:
hope it helps.

3 Likes

Lack of trimming is not something I had ever thought of. I thought it was just on by default. It would jive with the experience I had with the computer, it worked fine for about 3-4 months and then started giving me issues. I thought the trimming was covered by the scheduled defrag/optimization, is that not correct?

I ran the query, and the result was a 0. So disabled? Was this maybe disabled because of the bitlocker full disk encrytion? My understanding of trim is that it’s zeroing out bits that aren’t in use anymore?

I checked the SMART data with Crystal Disk Info and it says the drive is in good health. Available Spare is 64 and the Percent Used is 2. So SMART thinks everything is fine?

it just says its good or good 64?
if its good 64 then your drive has suffered wear comparable to 3 years+ use.
its still good, but you have excessively worn it with the lack of trim

for comparison i ran cdi on my nvme which is a year old 93% averaging half full.
my 840 evo was a boot drive for 3 years 78% , and has been a secondary kali o.s for the past year.
so yeah your good, you caught it in time by the looks of it.

turns out im a retard or the guy who wrote fsutil doesnt get what a double negative is.

apparently fsutil behavior set DisableDeleteNotify 1 disables trim when set to enabled.
so the correct setting is

fsutil behavior set DisableDeleteNotify 0

again apologies.

2 Likes

OK, so it “Available Spare = 64”, but I’m pretty it was reporting hex so the decimal number was 100.

So according to you second message the trim appears like it was enabled.

Based on this, I’m going with some kind of hardware issue. Lowest hanging fruit I think is the drive itself? I’ve already dropped the laptop off with the helpdesk to get it fixed, so this is purely an academic exercise at this point. Any thoughts on a way to point at the SSD versus the RAM or the MB?

Check all cables connections. In the case of External Hard drives, most of the I/O device errors occur due to cords and cables that connect the external hard drive to the computer. Therefore, the first thing you should do is to check the cord connections with your computer system.

well this is confusing. so i did the fsutil behavior set DisableDeleteNotify 0 and my drive stopped trimming.
ive set it to 1 again and will see if the scheduler kicks in…

ggrrr i hate trial and error coz some ones been deliberately pedantic. (thanks m.s devs)

1 Like

Update from the helpdesk, they have replaced the drive and after imaging left the machine running overnight. It did not crash or have any unusual behavior. Sounds like drive was the issue, so I guess I get to keep troubleshooting accreditation for now. :stuck_out_tongue_closed_eyes:

@HEXiT How do you know it stopped trimming? It’s still not clear to me what the difference between DisableDeleteNotify and Defrag/Optimize is. Is DisableDeleteNotify jsut doing the trim in real time and Defrag/Optimize is on a schedule?

hmm so i delved deeper it turns out windows doesnt trim by the settings in storage optimization.
but rather runs 1’s a month. (according to there doc)

  • Traditional optimization processes . Includes traditional defragmentation , for example moving files to make them reasonably contiguous and retrim . This is done once per month. However, if both traditional defragmentation and retrim are skipped, then analysis isn’t run. Changing the frequency of the scheduled task does not affect the once per month cadence for the SSDs.

so i guess im setting it to 0 again and reporting back next month… :confused:

1 Like

So even when it says it’s trimming…it isn’t? Windows is weird.

good news is my drive is now trimmed.
ffs microsoft talk about making things difficult to understand…

fsutil behavior set DisableDeleteNotify 0 =enabled. :confused:

2 Likes