Help with Virtualbox (and Sabayon)

So in my quest to learn about Linux, I've installed Oracle VirtualBox so I can try out various Linux Distros. 

Host - Windows 8.1 64bit.

I've read through and watched tutorials on how to set up VM's and thought I had done so correctly but things aren't working like they should and i can't seem to figure out why - even after searching for answers.

First I tried Debian. I created an 8GB partition VM for Debian 64 bit and installed from the ISO to that VM. It runs fine and I can play around within no problem - for the most part.

Next I tried Sabayon 14.06 KDE (amd64). Again, I created another VM, this time with 16GB partition (because it's a larger distro) and installed from the ISO. It runs, but there are issues; During the installation I setup a username and password as well as admin/root password - yet it never asks to log in upon boot and it will not log out. When I try to log out it simply reloads the KDE desktop as if I did nothing. It also does not retain any changes I make after shut down and reboot. 

I watched a few tutorials on setting up Sabayon with a VM in VirtualBox, but I noticed some of the options and steps during installation were not the same or different than what I see when I go through the install, thus I can't follow those exact instructions.

Also can't seem to get steam to work within Sabayon either. It downloads and installs but then says there's not enough memory - I guess allocating 2GB ram for this VM isn't enough? I tried allocating 3GB ram but now steam doesn't respond at all (does nothing when I click on it).  

And that's not all. At times certain apps just don't respond (like steam) when I try to run them. It just does nothing. Enabling 3D acceleration for this VM seems to cause issues like this. Not sure why 3D acceleration doesn't work but haven't looked into that yet...


Just wondering if any of you can help me out or at least point me to some more resources as I can't seem to find clear answers or figure out what I'm doing wrong.


Any help would be greatly appreciated. Thanks. :)

Ok, I believe I figured out what I was doing wrong. And yeah, I'm a total nOOb at this kind of stuff... *facepalm*

Realized I had to remove the Sabayon ISO from the "virtual disk drive" - otherwise it just kept booting from that instead of the VM's "virtual hard disk". Now it works just fine. 

Mods, feel free to delete this thread if necessary.