Help with starcraft issue

Hey guys, long time and no see.

As some of you may know, i play games on an OLD comp and just purchased a 8400 GS for it (ugh, PCI slot board)
after i install the card/drivers and stuff, i played starcraft and the picture SUCKED. the computer was just simply not updatng the picture when things in the game happened, and its basically unplayable. I asked my father about it and he said that the card is too "new" for the game and that the game was designed to run in, like, directx 2 and run on older cards.

are there any drivers i can get to have it learn how to run on this new-ish card?

to be honest, saying a card is too new for a game is a bit ridiculous, don't you think?
I think for starcraft, if you log into the game will update itself so try that first.
have you tried playing any other games to see if they were playable?

well, basically, its like a directx 4 game, and it was designed to work at a diff res with a diff card, and it doesnt know how to send this signals to the gpu correctly

and yes

I have a 7900 that StarCraft plays on just fine.

The only Game I have come across that actually gave me an error because my GPU was too new, was "Thief"Â and it is because they used a weird pixel shader instruction.

I think there is something else going on with your system.

ok, i tried opening "properties" and i change the compatibility mode settings. it makes the game switch over to windows 95 when i want to play the game, and switch back out when im not playing. i switched all the settings to what it should be and now it doesnt run. it only prompts me saying "starcraft failed to read a file, the disc may not be in the disc drive" or something.

now what?

Do you have the original game with CDs?


You are running XP?

yes :P

is that bad?

Strange, i had SC on Windows XP as well and mine worked perfectly, if it wud have been Vista then thing wud have been different.
Strange issue you have then.

is it possible i need more RAM or a better processor?

RAM= 512mb

CPU= Pentium4 @ 2.8 ghrtz

these are some strange issues, yes...

yes i know :)