Help with 980ti, asrock x99, DDR4 Boot issue

So I'm building a PC here are specs

Intel Core i7 5820k 6-core @3.3GhZ
Corsair H100i
Asrock x99 Extreme4 Motherboard
Samsung 850 Evo 250GB SSD
HGST 2TB Internal Hard Drive
1TB External Drive
Gigabyte GeForce 980ti 6GB GDDR5
EVGA 750w Power Supply
Rosewill RISE case

And I'm having some serious issues I can't seem to figure out.
Lets start:

This is the second 980ti I'm trying. I can't get anything out of the POST, nothing appears on-screen. The mobo has no iGPU so I can't verify there, but when I remove RAM, I get the 'missing RAM' beep code. So I'm guessing it isn't that, but I have no way to verify without an additional DDR4 mobo. This is also the second set of RAM I'm trying.
Basically, I've checked:

All connectors
Proper seating of CPU, GPU, and RAM
A low end GPU (still nothing)
Cmos Reset
cmos clear

Additionally, both 980ti's didn't work in separate machines (an older amd 6core and i5) either, and won't even POST. I'm at a loss because I don't know what else to do, or what I could be missing.
This brand new 980ti I got today didn't work in the build, so I tried a different machine, which won't even power on. (FYI, this machine works fine otherwise, and currently houses a GTX Titan with no issues).

This is the third time receiving revised items from newegg, I want to add. First box was so water logged, I opened the 980ti box to find visible moisture on the inside. So I RMAed and got another set, that didn't work for either machine. Now, I'm on yet another set that seems to be having a similiar issue.

Any ideas? Any input would be appreciated, I would really like to figure out what's going on.

Could be that your PSU is bad and is killing the cards, otherwise did you try the titan in the X99 system?

I also hope you have a 4k display to stress that 980ti with.

1 Like

Thats a good idea. I'll try that now.

I had a similar problem last week while upgrading my coworker's laptop. It turned on, but wouldn't POST. After trying everything, i cleaned the RAM sticks with a q-tip and alcohol. It worked after that.

So I tried the ti in yet another computer, now it works. Weird. I'm getting display. Also, I used a 280x to test instead, and it doesn't POST still, but the 280x works fine in another machine, before and after visiting the X99.

I think its a bad mobo. Strange, cause everything powers up, I just don't get display. I'll double check the RAM again- but this was in the 'Open box' bin so I might have to RMA it

Did you try other PCI-e slots?

hm, also something I will try right now.
But the manual says #1 should be the only x16 slot populated in a single gpu config... Could there be anything else I'm missing?

it'll be fine in the other slots, even a x4 3.0 slot, the performance hit would be minimal

Just tried that, and tried a low end card that doesn't need any power connectors (also works in other machines) in all slots and nothing. I just noticed that fans are stuck at 100% too, doesn't do anything after 10secs like a normal POST.

I'm thinking its the mobo.

Hmm thats odd.
Did you allready try to re-seat the cpu?
Also since you have more systems, you could try to switch out psu´s.

  • Also try if it boots with only 1 memory stick installed.

Do you have any additional usb devices connected other then keyboard and mouse?

Hm, trying a seperate PSU is something I have yet to try. I'll double check my CPU seating, I'm new to this socket but I'm pretty positive I've got it right. Single stick didn't give any other results.
No other devices besides keyboard/mouse. I've also tried to remove all other devices (SDD,HD,CD) as well.

So I've since tried to reseat the CPU and checked my pins, nothing there. Also tried a spare PSU, same results. I think thats it, unless you guys got any other ideas, I'm think its the mobo.

One last thing, I notice a red LED stays on long after the PSU was unplugged... weird?

Nah sometimes the psu caps can power a led for quite a while, you see it sometimes too on mobo leds

1 Like

I had an issue like that once where the cables weren't completely plugged into the gpu, it wouldn't give me post beeps indicating what was wrong but wouldn't post either. Also a different time where there was a floppy disk connector plugged into a fan header (friends 14yr old built the comp) so it wouldn't post at all.

I'd take the stuff out of the case and build it on some cardboard, to try to eliminate the possibility of a case short.

I haven't double checked my mounts, so I guess I could do a case-free run tomorrow before I take it back, should be simple enough.

If you have tried with one stick of ram, switched out psu´s, disconnected all other usb devices other then keyboard and mouse.
Then i think you might indeed have a bad motherboard.
Since you also tried other gpu´s in the system.

Contact Asrock or the shop you boaght from, and send it in for an rma.

It could also be that your cpu has a bad IMC, but then atleast it should have booted with a single stick of memory.
In this case it looks to me, that you have an issue with the motherboard it self.

Interesting, well I would hope its not a bad CPU. I'm guessing its the motherboard, and I will find out later today. The mobo was an 'open box' deal at microcenter. Thanks for all the help.

EDIT: Figured it out, twas the mobo. CPU is fine, finally running. Thanks so much for the help everyone.

1 Like