Help thread for newb installing arch

Hi, as per the suggestion of @Goalkeeper I am creating a help thread spawned from this thread Now to start off I have a problem with grub, as when I run the grub-install command it outputs:
grub-install: warning: Attempting to install GRUB to a disk with multiple partition labels, This is not supported yet
grub-install: warning: Embedding is nt possible, GRUB can only be installed in this setup by using blocklist, However, blocklists are UNRELIABLE and their use is dicouraged
grub-install: error: will not proceed with blocklist

What's wrong with my blocklist? Please help

1 Like

hey, im a noob but i installed arch a few times, i think that this is because you didn't create a separate boot partition (don't know if you're installing bios or uefi), there is a way of installing without one (i dont remember how it worked or if it still works) but using a boot partition is recomended (or efi partition if booting uefi), if this is the case i would shrink a partition (probably the one you chose for / ) to make a boot partition (or efi partition).

forgot to mention that if you're booting uefi the efi partition is necessary

Bios, it's an old optiplex 960, and I am following a tutorial of some guy, and I have set up sda into 3 partitions of sda1 (boot) sda2 (swap) sda3 (everything else) so I'm a bit confused, since in this turotial he installs grub fine with these 3 partitions, so should i specify sda1?

Oh shit, I think I know what I did wrong, when I was doing the genfstab command, I had it directed to /etc/fstab instead of /mnt/etc/fstab, and I issued the command from within the chroot

I'm retarded

That solved it? Your chugging away on your install now?

I'm on the toilet writing this from my phone, once I get up and wash, I'll go over and try to undo my mistake, also is it safe to delete the file in /etc/fstab, I find that accidents like this typically have unseen repercussions in the future, so how do I safely diffuse this time bomb?

I don't believe it's safe. If it's the one from the install it's there to be edited.

Oh fuck, I did the genfstab command correctly

1 Like


Does anyone have any idea what grub is doing? I think I did everything correctly

did you chroot into your new install?


what command are you using to install grub?

grub-install --recheck /dev/sda
inside the chroot

not sure why this happens, might be that the boot partition is not flagged as bootable?

1 Like

It sure as hell is, I just did fdisk, do I need to check from within the chroot?

not that i know, might be worth checking the arch linux wiki page on grub

Thanks, but I just can't get grub to install, it's really annoying, I set up a partition as the MBR, but still, nothing