#HELP! Remote File Access, I fell down the rabbit hole and can't get out (webDAV, SMB, nextcloud, VPN)

Briefly, I have tried a few different options for getting access to my data at home, I feel I get 95% of the way there but I keep encountering walls.

My solution has only been a win7 SMB share that I access on my local network and is in need of an upgrade.

My end goal is to access my files remotely through File explorer and ideally map a network drive

My first thought was get a VPN tunnel to access my network, Great, ready go!

Took a little bit, but I found the Softether project, got it setup and for once it just worked… But SMB does not work well over the internet, I read it has something to do with latency… Awesome, I can see my files, but accessing them isn’t practical if it’s even working at all.

Ok, off to find something else.

Seems like webDAV would be a good solution, and Windows can do that natively. After struggling with that for at least 8 hrs I gave up.

I followed several different tutorials and got stuck when trying to access the webDAV from other computers on the network. I was able to access it on the computer that was hosting it. and I’m not sure where the disconnect is. I tried this on my main win7 “server” and I even tried a Win 10 pro on a laptop and got stuck at the same spot. Not sure why other computers on the same network can’t see it.

Now that I have the VPN tunnel, an internal webDAV server would be fine, but it would be niceto have external access, I somewhat know how to deal with dynamicDNS so I might play with that if I get past the internal file hosting phase.

So Windows IIS webDAV isn’t working for me, so again I search.

I came across NextCloud and that seemed pretty promising, Has a bunch of features I don’t need, but would be nice. I just want the webDAV…

Found that a lot of people are using docker for this, and since I can do that all inside of Windows, sure lets try it.

Long story short, Installed fine, loaded and did initial setup fine, but this is where the information stops… I don’t know how to access the config file to allow the stupid computers ip address to be a trusted domain, SO I CAN ONLY ACCESS IT FROM THE LOCAL COMPUTER! :scream: :sob:

While trying to figure out this issue I noticed something about SQlite having an issue with larger databases. I only vaguely understand what that is and the prospect of troubleshooting it when I’m still down here struggling makes me want to cry… It’s times like this that I wonder how I ever got into computers. :weary:

At this point I don’t know if I’m supposed to have access to my files via http(s) and I’ll just have to live with the flashdrive.

The last thing I have is trying ubuntu on metal and get nextcloud running on there exclusively, should hopefully be able to access the config without my head exploding, I just have no idea how docker works, but I like the capabilities it offers. I, just… Don’t know how to use them…

I don’t know what I don’t know. Please help.

What are you hosting the data on at home and how much do you have?

Are you sure your home internet has fast enough upload for remote access

Thank you, @ucav117 @nx2l

(TLDR internet is probably fine)
My connection feels fine when I use that diy VPN to my home network. I don’t remember what it benchmarked at, but I don’t remember it being bad, and streaming content works flawlessly. When I’m outside my network I don’t really notice whem I’m using my VPN other then a little bit of latency. So I assume my upload is fine.
The only way I have been able to benchmark my file transfers is through SMB. I’ve had limited success with CAD files, but it’s not stable enough for mp3 or mp4. Hense trying to host the data via http

The two systems I have tried

Main Server
Win7
Amd phenom xii 4c4t
12Gb ddr3
9 HDDs 1-4TBs
Shared drives (SMB)
VPN Server
Tied IIS webDAV, but could only access it on the localhost, if I get this up and running I’d be happy.

Test laptop
Win 10
Intel i5-9300H 4c8t
8Gb
500gb ssd
This is the one I have docker/nextcloud/portainer installed on

I can access nextcloud and portainer from outside my network through my VPN, however changing the the trusted domains in the config file is hanging me up on next cloud, as well as whatever can of worms might come along with hosting that volume of data on that platform.

At a minimum I would like to host a 4TB drive that has 2-3TB of the typical NAS stuff, media, programs, docs, etc. And be able to giltlessly dump all my files back onto it, bandwidth being my main concern, being stable on a variety of latencies.

Any advice?

While running Nextcloud in a Docker container you can find the config.php file in the data folder of the container. In there you need to add a line under “trusted domains” that’s exactly like the one above it (minus you gotta change the 0 with 1) and put the domain between quotes.

P.S. webDav on Nextcloud doesn’t refresh the files on the Nextcloud istance automatically so you’re gonna need to do it manually with a command I can’t recall.

Ok, so that was helpful, I was able to locate and pull the config.php file using the docker UI under the volumes tab, then the data tab of the nextcloud volume. Edited the file, now in typical fashion I’m just hungup on copying it back onto the volume. Lol :sweat_smile:

I’ve seen a few options for this, but I’m not able to get the file to move using powershell and that seemed the most straightforward. I wish I could just drag and drop it, or that docker had an import function in the UI.

Can you modify the file directly from shell? That would be the most convenient way to do it.

How do you access the machine where Docker is installed? You could do an SSH copy or use sftp through Filezilla.

Ok, so apologies in advance, but I’m completely out of my element with this.

I access the computer through TeamViewer/rdc, or physically.

I don’t know the first thing about editing files through shell, but I agree, that sounds the most straightforward. However I don’t even know how to navigate to the file, being a linux filesystem in a docker container.

I have tried connecting to the server through PuTTY, but I don’t know what im doing.
I’ve tried typing in localhost and running at the default port 22
I tried the ip of the container running nextcloud along with ports 22,80, and 8080 and none of them connect.

Docker data files are outside of the container.
When you deploy the Nextcloud container there are some binds required. One of which is for the Nextcloud data files.

Change localhost with the local IP of your machine. Use port 22 and log in with username and password of a user that’s on the machine.

Make sure to NEVER expose the SSH port outside.

Are you saying I should be able to find the files locally on my hard drive? I’ve looked around in the Docker Program Files and found an archive called services.tar thats 528MB so I poked around in there but there’s alot and from my poking around couldn’t find anything pertaining to Nextcloud.
Looking in dockers appdata I was able to find two vertual disks but cannot access them through windows because they are in use, I’ve closed docker completely to see if it would relinquish them, but I’m still unable to browse them.

As far as SSH, I typed in the IP of the laptop I’m working on and the terminal is still blank and comes up with a connection issue.

I set my IP address to a static one
I open PuTTY
type in my static IP address and leave the port alone because it is already filled with 22
hit connect
and nothing
I also used the IP that docker gave the nextcloud container.

Am I missing something?

Trying shell, Im not sure where the config folder would be located or if the the format of the request is correct.

I’ve tried this in powershell

docker cp C:\temp\config.php 933afa009ce:/config

And I get “No such container path”
I kind of expected that cause I can’t see the whole folder and file structure. If you know what I’m supposed to put in for the location, that would be huge.

933afa0009ce is my container ID in docker for nextcloud
C:\temp\config.php is where the config file is located on my laptop.

Is it ok that I’m trying to move the config file from c:/temp?

I have another suggestion.

Since Vista times Windows sharing has always been a pain for me to make it work, but because I use it to move files(as opposed to mount and use mounted) , at some point I fount out how to use the FTP share and never looked back. Here’s a tutorial:

Just don’t go too far, make it accessible inside your VPN, not publicly :stuck_out_tongue:

FTP is the simplest protocol, I can remotely watch movies on my phone using it and my VPN, almost any app will support it, not to mention being able to just type ftp://user:[email protected] into firefox/windows explorer and access the files.