Help needed with VGA Monitor on Manjaro

Hi there.
One of my Monitors recently died and the one I’ve grabbed from the pile I had lying around doesn’t appear to be working on my Manjaro. It is a VGA Monitor that is hooked up via a passive adapter to the dvi port of my r9 380. It is being recognized by Xorg as it shows up for selection in my Display settings. It also mirrors my main monitor during boot. I’m a little lost on how to troubleshoot this. Any reply would be appreciated.

It could be that the resolution that you are trying to pipe to the VGA monitor is out of range. You can only get 1080P through a single DVI-i and 1440P through a DVI-i dual link. With that said, your monitor may only support something between 1024x768 - 1200 x 1024

Only DE that was friendly enough with me and dual monitors was gnome, and a bit of kde.

I’ve always used my vga monitor with a dvi adapter and it was always ok, your problem is most likely to be with the screen composer or whatever, if it mirrors your boot screen the monitor and adapter are probably fine, try a live USB with gnome

but first please elaborate on the statement:

I am using the gnome DE. The screen just stays black, but it does not report that its missing the signal. Just blackscreen. I’ll tryout some other live image later. I’ve also tried different resolutions without any luck. The Monitor is a Samsung SyncMaster 2243SN if that matters. It’s supposed to be able to do 1080p.
Thanks for helping me.

what happens if you use only this monitor?

you get signal?

tried dangling the connectors?

Yeah wiggled the connectors, tightened the screws, tried a different cable (only have one adapter though). I tried the screen as the only single screen, I also tried different resolutions. Just now I booted into a freshly downloaded copy of ubuntu to find out that its got the same problems. I just hooked it up to my laptops native vga port and it does work here as intended (its running pop_os 18).

might be the adapter then

not sure

are they cheap? you could try a new one

So if the vga monitor is the only one connected via the adapter, and it shows the UEFI/BIOs and the boot sequence, then dies at login, you might need drivers?
Can you access was other tty screens for a CLI interface?
If not, Problem might be deeper than gnome.

Dunno the Adapter is a tad older, came with one of my older gpus from gigabyte. Also I can access cli and everything else fine, its not my primary monitor, so if you know how to troubleshoot it pls let me know. I too suspect it to be a driver issue.

That is interesting. I am running DVI-i to two 1080 monitors on my setup. With no issues. I am running GCN1.1 with the amdgpu driver.

Could be that dpms causing issues. Powerplay does not work on GCN1.1 or older cards so I have to disable DPMS explicitly adding amdgpu.dc=0 to my kernel boot arguments. You could give that a try to see if this makes a difference.

Also, is Free Sync (VRR) turned on? If so, then the VGA monitor is not going to know how to deal with that. This can be turned off with the above as well. Also, make sure that both monitors are set to the same refresh rate.

And clarification. When you say you get a blank screen, is the montior showing that it is on? If you bring up the OSD and look for current information/resolution, does it report anything?

Does it work on boot-up before the GUI starts?

Try posting the output of: xrandr

The output of xrandr, xrandr --listmonitors, and xrandr --listproviders respectively. Haven’t tried kernel boot params yet.

Screen 0: minimum 320 x 200, current 2560 x 1440, maximum 16384 x 16384
DisplayPort-0 disconnected (normal left inverted right x axis y axis)
HDMI-A-0 connected primary 2560x1440+0+0 (normal left inverted right x axis y axis) 596mm x 335mm
   2560x1440     60.01* 
   1920x1200     59.95  
   1920x1080     60.00    50.00    59.94  
   1600x1200     60.00  
   1680x1050     59.88  
   1280x1024     75.02    60.02  
   1440x900      59.90  
   1366x768      60.00  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
DVI-D-0 disconnected (normal left inverted right x axis y axis)
DVI-D-1 connected (normal left inverted right x axis y axis)
   1920x1080     59.93 +
   1600x1200     60.00  
   1680x1050     59.95  
   1280x1024     60.02  
   1440x900      59.89  
   1280x960      60.00  
   1280x800      59.81  
   1280x720      59.93  
   1024x768      60.00  
   800x600       60.32    56.25  
   640x480       59.94  
Monitors: 1
 0: +*HDMI-A-0 2560/596x1440/335+0+0  HDMI-A-0
Providers: number : 1
Provider 0: id: 0x59 cap: 0xf, Source Output, Sink Output, Source Offload, Sink Offload crtcs: 6 outputs: 4 associated providers: 0 name:AMD Radeon R9 200 Series @ pci:0000:01:00.0

Looks like your second monitor just isn’t set-up to do anything. Try some variation on this:

xrandr --output DVI-D-1 --mode 1920x1080 --right-of HDMI-A-0

Well yeah, I disabled it because it stuff got put on that monitor which I couldn’t see also my Mouse got trapped there when I did go across monitor border which was just annoying because nothing got displayed. But still everything is black after that command.