Help for linux oc

is there a good guide on how to oc an amd rx 580 8g in fedora somewhere? I’m trying to figure it out and i’m having trouble understading what i need to do.

AMD or nvidia?

amd rx 580

Assuming you are using the open source drivers. Here is a guide (look at the overclocking section):
https://wiki.archlinux.org/index.php/AMDGPU#Overclocking

Make sure you have a recent kernel (4.17 and newer) and the newest drivers you can. Changes are not persistent across reboots and resuming from sleep resets the power limit for me.

Some useful commands (so you can figure out what you can actually change):

This is what I do in Kubuntu to overclock my RX 480:

The commands are slightly different than the Arch guide due to permission funkiness in my distro.

Here is the rundown:

  • First command specifies the clock and voltage I want to set. The settings are the characters in quotes. “s” specifies I will be changing core speeds (use “m” for the memory). The second number is the frequency step I will be modifying (in my example the last one which is the boost clock). The third number is the new frequency in MHz. The last number is the voltage in mV.
  • The second command applies the new settings.
  • The third command is to set the new power limit (you can do this first if you want).
1 Like

what command would i enter to only change the core speed since the command to figure out my voltage states just comes out blank.

Did you add the boot parameter before attempting any of this? It’s the first step in the linked to guide. Add amdgpu.ppfeaturemask=0xffffffff to your /etc/default/grub file (remember to run update-grub after saving the file).

The Overdrive command only works if all the parts are filled in (leaving out the voltage does not work for example).

2 Likes

yes I did.
this is my grub file
GRUB_TIMEOUT=“10”
GRUB_DISTRIBUTOR="$(sed ‘s, release .*$,g’ /etc/system-release)"
GRUB_DEFAULT=“saved”
GRUB_DISABLE_SUBMENU=“true”
GRUB_TERMINAL_OUTPUT=“console”
GRUB_CMDLINE_LINUX="amdgpu.ppfeaturemask=0xffffffff resume=/dev/mapper/fedora-s$
GRUB_DISABLE_RECOVERY=“true”

1 Like

That’s odd then. I assume you also ran update-grub after editing with no errors on the console?
What about the other commands? Does checking your power limit return any value?
I’m not on my machine right now, so I can’t check, but there are other commands you can cat to get info. Inside /sys/class/drm/card0/device/ there are several files you can check. You can press tab to get a list. There is one to check current memory speed and another for core. See if those return any values.

cat /sys/class/drm/card0/device/ >> press TAB

when i try to update grub
update-grub: command not found
but i used grub customizer to update it

[[email protected] ~]$ cat /sys/class/drm/card0/device/hwmon/hwmon0/power1_cap
145000000

[[email protected] ~]$ cat /sys/class/drm/card0/device/hwmon/hwmon0/power1_cap_max
145000000

It might be important to disclose what distro you’re using cause update-grub might just be for Ubuntu. Fedora uses grub2-mkconfig > /etc/grub2-efi.cfg.

i did in my first question, if you read it.
when i do sudo grub2-mkconfig > /etc/grub2-efi.cfg
it says permission denied

Are you on BIOS and not UEFI? Do you have a EFI folder mounted?

I’m on uefi

I’m on uefi but im not sure if the efi folder is mounted how do I do that?

Have you tried this? : https://github.com/marazmista/radeon-profile/blob/master/README.md