Headphones and microphone not working

So I installed linux mint (17.3) the other day and now i can't seem to get my headphones or even microphone working. I only managed to get sound out of my monitor when it was connected with an hdmi cable.

Headphone: Superlux HD668B
Microphone: SpeedLink something something (3.5 mm)

I have attempted the following:


Results: no luck

OK. Please connect your headphone and go to settings->sound. Does it show up?

no, it only says "dummy output"

OK. Try sudo apt-get update; sudo apt-get dist-upgrade

Does this give you an error? Did it upgrade any packages?

nope and nope

OK. Try this: cat /proc/asound/cards
It should show all your audio connectors.
Do you see your headphone jack?
If this output is empty, ALSA cannot find your headphone jack and therefore no headphone connected to it.

It only outputs this

HDA ATI HDMI at 0xdfe60000 irq 131

My headphones are connected to the jack

Then we've found the problem: Your jack is not recognized.

The shown connector is your HDMI port which you have been able to use.

Your standard 3.5 mm audio jack should look like this:

2 [Generic ]: HDA-Intel - HD-Audio Generic
HD-Audio Generic at 0xffb60000 irq 16

How old is your PC? - Linux Mint uses a relatively old kernel (= 3.13 - current stable version is 4.5.3) and builds on top of Ubuntu 14.04 (O.o WTF?!) - which maybe has no driver support for your connector.


Switching to Ubuntu (GNOME) 16.04 might help.

My pc is very new


  • Motherboard: MSI Z170A KRAIT GAMING
  • CPU: i5 6600K (Using stock clocks [3500 mhz] )
  • CPU cooler: Be quiet! pure rock
  • GPU: SAPPHIRE R9 390 NITRO (stock clocks)
  • PSU: EVGA G2 650W
  • Case:Fractal Design Define S
  • RAM:Crucial Ballistix Sport 2400mhz
  • C: Drive: SSD Samsung 850 Evo 120gb
  • D: Drive: WD Blue 1TB (7200RPM)

OK, cool. Then Linux Mint might be too old - They build on top of packages from 2014.

You can upgrade the kernel from the updates gui (view > linux kernels), no need to jump on another distro.
If you installed the proprietery graphics drivers, make sure to uninstall them before you upgrade the kernel, then reinstall later

@Thiman OK, maybe try that at first.

well, that didn't work ;_;

Allright, then try this: rename the "Pulse" folder in /yourhome/.config folder to "pulsebk", then reboot (reveal hidden files & folders in the file manager with ctrl-h)

I would bet that this is not going to help, since ALSA is unable to find the connector and therefore pulse can't do anything.


Aye, the idea was if the kernel upgrade didn't resolve the issue then the old config should be removed as well if it's causing issues with the new drivers.

@Thiman Speaking of which, does

$ cat /proc/asound/cards

come up with anything after the kernel upgrade?

Which kernel did you install?

$ uname -r

If you're running a 4+ kernel but still lack drivers (which would be super odd) you can install the drivers manually as per described here https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS

Nevermind, thx for the help though.

I have already switched to ubuntu Gnome :P

1 Like

Since I have been distro-hopping, sound doesn't work in most distros out of the box for me.
I have 3 sound cards in addition to 2 inbuilt.
What I end up doing is launch some long (1 hour) youtube-video while troubleshooting.

Install pavucontrol.

sudo apt-get install pavucontrol (Ubuntu-based)
sudo zypper install pavucontrol (Opensuse)
sudo pacman -S pavucontrol (Arch-based)
sudo dnf install pavucontrol (Gentoo-based IIRC)

Launch it by just typing: pavucontrol
In a terminal. It probably mentions CubeUtils in the GUI-app.
Then switch output to the soundcard I want. If that doesn't solve it, I run:

In terminal

Select my soundcard (F6). make sure the channel isn't muted (big MM). If it is, navigate to the channel with arrow-keys and press M to unmute.

Those 2 steps has solved all my sound problems so far in 4 different distros.