Hdd help

I have a 3tb hdd for data on my win 10 pc. Its been working great until recently. All the folders will open fine except 1 folder(downloads) when viewed in my computer(this pc). That hdd is separate and does not have win 10 on it. It writes to the download folder fine and can open things through apps from download folder. But when i try to open it through my computer to view the files in the folder it says “working on it” for a long period of time and then it eventually says not responding. If i try to close it i have to click “x” multiple times and then it will close and then i believe explorer.exe crashes because programs close that were open before and they do not re-open.

Any help would be greatly appreciated on fixing this issue thanks!..is my hdd starting to go?

Does this only happen when you try to open the download folder or does it do the same when opening documents, pictures, or other folders (if you have those folders on the 3TB and not on your Windows 10 drive)? What drive are you using for Windows? Does this happen when you navigate to the downloads folder another way besides the quick link? My gut feeling is that your hard drive is fine, but Explorer might be confused.

windows 10 is on ssd along with the pics, docs, etc.

it does not happen when i open a video from downloads folder in vlc for example.

it just started doing this a few days ago. i dont know what the problem is.

Quick way to see if the hard drive has issues is to use a utility like CrystalDiskInfo to view the SMART info in something that is legible. It will actually say good, bad, caution at a glance. If that looks ok, which I’m betting it will, then I would recreate the download folder link in explorer and see if that helps.

downloaded and that program says health status is good. I completely removed the link(quick access link) from my computer. Just navigating to that folder on that hdd through my computer makes it not work and explorer crash(i think its explorer.exe) screen goes black for a second then comes back with programs/apps closed that were open in bottom right.

I’d open explorer, right click on the drive, go to properties, then the tools tab, and run an error check on it. Could be an issue with the file table, which chkdsk should find.

ya i ran that earlier it didnt find anything :frowning:…same thing now

it seems to keep making that folder read only as well. i changed it and hit apply then close it out and re open it and its back to read only…idk if that helps

yeah, ignore the read only square in the properties window unless the box is completely full. That’s normal. When was the last time you were able to write something to that folder? I think you said you downloaded CrystalDiskInfo, did that go to the download folder by default? How did you navigate there to run it, or did you just install from the browser?

I would start with an SFC scan because that is easy and it will eliminate Windows as the problem (hopefully). Open a command prompt as an admin and type “sfc /scannow” without the quotes. Next step if that is clean is a test of the drive to see if SMART isn’t reporting an actual problem.

1 Like

everything downloads to that folder. I downloaded that program to it and opened it through the browser.

will do cmd now…“Windows Resource Protection did not find any integrity violations.”

are you able to view the folder in detail view ? (no thumbnails)

im thinking there is an extension of some sort installed that maybe trying to thumbnail either a photo or a video and its crashing explorer. something maybe like icaros http://shark007.net/tools.html.

if there is no alternative thumbnailer on your machine it still maybe a corrupt video or photo thats actually causing the windows thumbnailer to crash . or maybe even a corrupt file pdf, office doc, etc…

the best recommendation is to get an alternative file manager something like

and see if you can go to that download folder …

and start eliminating files by moving files out of the directory to a new one .

best done by splitting the contents in half and then testing the directories in explorer.

repeat the process until you narrow down the file. causing the problem

and oh yeah simple thing first … when your in that cmd window try deleting thumbs.db see if thats helps

1 Like

@DigitalBytes @chaos4u thank you for the help! I was able to open the folder with freecommander and delete the files that caused the issue. problem solved! thank you both for the help, I greatly appreciate it!

close thread