Return to Level1Techs.com

Having Issues With Purchased KVM

Hello,

I purchased the Display Port 1.2 KVM Switch - Dual Monitor
SQ2625416

back in April, as a way to easily switch between my main PC, work laptop, and my server. It was working fine until this morning, I could not get any signal on my monitors from the KVM. I tried restarting the PC and monitors, but no go.

After work, I unplugged everything, and let it sit unpowered for a few minutes, and tried to hook up each thing in order slowly. First power, then monitors, then usb devices. This has not fixed the issue.

What I notice, is that the red light is missing, I only see a green light which indicates that the usb is plugged in on the back. It is plugged into a relatively new surge protector, but I did notice the oven clock was blinking, which makes me think the power blinked overnight. Any idea on what might be wrong, and how I can fix it?

Thanks.

Check the power brick is in good. Unplug it for a bit and plug it back in.

The kvms will work with any regulated dc 9-12v center positive dc adapter so if you have one that fits physically and is center positive you can try another power brick. The power brick also has a soft fuse that will reset after being unplugged for 30 seconds

So, for reference, the power LED is green when plugged in, I just don’t have a red light. I tried unplugging the power brick for a few minutes and tried it again, but still no dice. I have a router power supply that is the same connector and right polarity, but it is 12 volt 2 amp, will this work?

I tried the router power brick, and behavior is the same. Power light turns green, hear a small click, and then nothing. The number lights turn green when USB is connected, but there is no red light for what is supposed to be selected, and I am not getting power to the USB ports on the device. I used a different outlet to eliminate that variable as well.

Sounds like RMA. The red light is external power. Green light is usb power. Probably a power surge but maybe not.

Email me Wendell at level1techs.com to setup the RMA with your order #