Return to Level1Techs.com

Having an issue with running games at 1080p on a 4k display


#1

Having a bit of an odd issue here, folks. I have a 4k Samsung TV (3840x2160) and I am trying to play games on the TV using my Dell laptop running Ubuntu-Mate 18.04 with the Mate desktop. I have the latest version of both the Nvidia and Intel graphics drivers installed, and I have the latest version of the kernel (as of a few days ago at least). The issue is that when I play a game at 1080p on the TV the game opens in a sort of fullscreen borderless window and the TV appears to be scaling down to just that window, but when I move the mouse I am able to pan around my desktop. If anyone has an idea for how I would fix this (without manually changing my desktop resolution before I launch a game) please let me know.


#2

What I had to do with my 4k TV is change the settings when it was getting 1080 data. There is a setting on the TV that changes the perspective on the input and that had to be adjusted once the input was 1080. I don’t have a samsung, so can’t tell you where it is, but the issue was not related to the PC but the TV itself.


#3

I’ll give that a try when I get home and report back.


#4

Thats a no go on that, my TV didn’t even give me an option to change scaling settings. Here is a short video demonstrating my issue:

Also after exiting the game I have to manually set the resolution back to 4k.


#5

interesting, it’s almost as if it’s not sending the resolution reset signal back to the TV. Does your TV have different HDMI ports? I had an issue where one of my ports was not dynamic and had to swap it to one that was, I wonder if this issue is similar.


#6

I’ll be honest with you, I’ve had this issue whenever I have tried to run most games at lower than native res in Linux, it’s just that this is the first time I have actually had a need to run games at lower than native res.
Also switching inputs did not help. I’ll install and switch to Cinnamon DE to see if that changes anything.


#7

does your TV have an overscanning option? That can cause this

edit: my tv called this ZOOM and it was something I had to turn off

edit 2: to be clear, I have 3 TVs two 43 inch and one 55 inch, so have had a lot of weird things I had to do to get these working well together (one is an older 1080 tv too)


#8

The thing is though, I have never had this issue with Windows, only with Linux. That in addition to the fact that I have had this same issue with other displays leads me to believe that the issue is related to how Linux handles scaling the desktop for fullscreen applications. Also the behavior under Cinnamon DE is even stranger.


#9

This is getting odd to me. I’d check the nvidia control panel then. I just logged into my old box with an nvidia card and saw some options for auto flipping in the graphics option, so perhaps something there?

Another thought might be to try arandr once you exit an app and see what exact settings it’s leaving your desktop at, it might be something like the DPI is getting flumoxed somehow.


#10

So I tried arandr, it just told me the display output was running at 1920x1080. I’ve tried flipping damn near every option in the Nvidia control panel.

Edit: It IS changing the display resolution, but isn’t scaling the desktop to match it seems.


#11

With arandar you can flip the resolution back pretty easily, so that’s at least a workaround.

I seem to recall having a similar problem with the game Wasteland where it wouldn’t swap back, but that was long ago and a kernel update fixed that. You shouldn’t be seeing the problem at this point.

I’m wondering if there’s some way to force the system to reset the resolution after opengl is done being used.

Can you run nvidia-bug-report.sh ?

You could post this on the nvidia forums and see if they can give you a better answer.
I just am at a loss but I bet it’s some obscure config setting.


#12

Oh how I wish I wasn’t.

Done, here is the file:

https://1drv.ms/u/s!Ard5Ez3o2QyGge4dIUO9wWJo2wzsuA

And here is a copy of my xorg.conf that Nvidia settings auto generated:

https://1drv.ms/u/s!Ard5Ez3o2QyGge4edtZYklygMGEOaA


#13

I noticed you have this error:

321.627] (==) No monitor specified for screen "Default Screen Section".

Have you specified the monitor in Nvidia control panel?
It looks like the system is just switching to a default monitor profile, so perhaps forcing it may make a difference.

edit, a little bit more on this:

[ 321.627] (==) No Layout section. Using the first Screen section.

[ 321.627] (==) No screen section available. Using defaults.

[ 321.627] (**) |–>Screen "Default Screen Section" (0)

[ 321.627] (**) | |–>Monitor "<default monitor>"

[ 321.627] (==) No monitor specified for screen "Default Screen Section".

Using a default monitor configuration.


#14

Here’s another weird thing, it looks like nouveau is still installed?

[ 321.640] (==) Matched nvidia as autoconfigured driver 0

[ 321.640] (==) Matched nvidia as autoconfigured driver 1

[ 321.640] (==) Matched nouveau as autoconfigured driver 2

[ 321.640] (==) Matched nouveau as autoconfigured driver 3

[ 321.640] (==) Matched modesetting as autoconfigured driver 4

[ 321.640] (==) Matched fbdev as autoconfigured driver 5

[ 321.640] (==) Matched vesa as autoconfigured driver 6

[ 321.640] (==) Assigned the driver to the xf86ConfigLayout

[ 321.640] (II) LoadModule: "nvidia"

[ 321.640] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/nvidia_drv.so

[ 321.640] (II) Module nvidia: vendor="NVIDIA Corporation"

[ 321.640] compiled for 4.0.2, module version = 1.0.0

[ 321.640] Module class: X.Org Video Driver

[ 321.640] (II) LoadModule: "nouveau"

[ 321.640] (II) Loading /usr/lib/xorg/modules/drivers/nouveau_drv.so

[ 321.640] (II) Module nouveau: vendor="X.Org Foundation"

[ 321.640] compiled for 1.19.6, module version = 1.0.16

[ 321.640] Module class: X.Org Video Driver

[ 321.640] ABI class: X.Org Video Driver, version 23.0

[ 321.640] (II) LoadModule: "modesetting"

[ 321.640] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so

[ 321.640] (II) Module modesetting: vendor="X.Org Foundation"

[ 321.640] compiled for 1.19.6, module version = 1.19.6

[ 321.640] Module class: X.Org Video Driver

[ 321.640] ABI class: X.Org Video Driver, version 23.0

[ 321.640] (II) LoadModule: "fbdev"

[ 321.640] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so

[ 321.640] (II) Module fbdev: vendor="X.Org Foundation"

[ 321.640] compiled for 1.19.3, module version = 0.4.4

[ 321.640] Module class: X.Org Video Driver

[ 321.640] ABI class: X.Org Video Driver, version 23.0

[ 321.640] (II) LoadModule: "vesa"

[ 321.640] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so

[ 321.640] (II) Module vesa: vendor="X.Org Foundation"

[ 321.640] compiled for 1.19.3, module version = 2.3.4

[ 321.640] Module class: X.Org Video Driver

[ 321.640] ABI class: X.Org Video Driver, version 23.0

[ 321.640] (II) NVIDIA dlloader X Driver 415.27 Thu Dec 20 17:12:39 CST 2018

[ 321.640] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs

[ 321.640] (II) NOUVEAU driver

[ 321.640] (II) NOUVEAU driver for NVIDIA chipset families :

That seems weird to me, I’m wondering if you need to do the following in the /etc/modprobe.d/blacklist.conf :

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

edit: was just researching and apparently blacklisting modules is done a bit differently in the later kernels, it may simple be a blacklist in the modprobe


#15

Like so?

It is, however it is disabled as can be seen here:


#16

that looks correct to me

edit: would still consider blacklisting the nouveau driver


#17

Here are instructions on blacklisting for 18.04:

https://linuxconfig.org/how-to-disable-nouveau-nvidia-driver-on-ubuntu-18-04-bionic-beaver-linux


#18

Blacklisted Nouaveau driver, still havinng same issue.


#19

yea, at this point I’d post your stuff on the nvidia forum. There may be something that we are missing. You’ve done everything I can think of.


#20

That’s ok, thank you for helping, or at least trying to.