Has anyone actually used all the M.2 slots on the Z590 AORUS PRO AX?

As the title suggests, has anyone actually tried to use all 4 of the M.2 slots on the Z590 AORUS PRO AX? This was one of the key selling points of this motherboard back when RKL was fresh, and I bought into it thinking that I could deploy 4x NVMe drives for a flash array down the line with my DIY NAS.

Googling around, I haven’t really seen any evidence of anyone actually using all 4x of the M.2 slots for NVMe storage.

I’m asking this because I’m trying to add 4x SN630s 4 TB that I managed to get on clearance for “cheap” (brand new!; well cheaper and way better endurance than the QLC 4TB consumer M.2 NVMe drives on the market today). However, with the SN630s connected through a U.2 cable + M.2 → U.2 adapter (since it’s a U.2 drive) I can’t get the system to POST(!!!) with this combo connected to anything other than the M.2B_CPU port. Anything connected to the A, C, and SB ports results in the system not posting. I used to have the boot drive NVMe connected to the “A” port (which is the only port that works with a Rocket Lake CPU; which I’m using the 11400), and it worked fine (but was a Kingston A2000).

Here’s the MB’s topology with the slots annotated with what I’m using them for:

As for the troubleshooting, yes, I first tested every SSD with the one slot that did work (and every SSD did). I then tried all the U.2 cables, which all worked. I then tried switching around the M.2 → U.2 adapters, which all worked. But changing the M.2 mobo slot only is what makes things not work. At this point, I think it’s a compatibility issue since I had my “normal” gum stick M.2 Kingston A2000 worked in the top “A” slot. So the TL;DR: if you managed to successfully use all four M.2 slots, what SSD did you use? Clearly, my niche use case doesn’t work, I’m not sure why (too many adapters? Cables too long? SN630s not validated?), but I imagine the four M.2 slots must work or else Gigabyte wouldn’t’ve put them there. Oh and yes, I did try to force the top slot to Gen 3.0 only, and I did try x8x4x4 bifurcation for the top slot hoping it would allocate the lanes correctly to M2C, and these didn’t change anything with the not-posting issue.

The CPU and MB don’t have enough PCIe lanes to run all the SSDs and PCIe slots without tricks.
Gigabyte doesn’t make this very easy to understand in their manuals and specs.
Key is the MB block diagram on page 5 of the [user manual] and all the fine print thoughout (https://download.gigabyte.com/FileList/Manual/mb_manual_z590-aorus-pro-ax_e_1002.pdf?v=2fd1dea854ecfccb387ef98342be4529).

“The PCIEX16 slot operates at up to x8 mode when a device is installed in the
M2B_CPU or M2C_CPU connector” (p.8)
“The M2P_SB connector shares bandwidth with the SATA3 1 connector.” (p.20)

Also, there are multiple occations where a footnote states that M2A M.2 slot is only supported by 11th gen CPUs (p.8,p.19,p.20).

All of this should not result in non-posting, though. This may be due to a bug in the UEFI or due to the use of enterprise U.2 SSDs.

I have several Micron 9300 U2 SSDs and experience weird behavior in the UEFI whenever they’re connected. May be related or not, but wanted to share this anyhow.

I did take a look at the manual a long time ago. The top PCIe slot (as indicated by the image) is unpopulated. I do/did expect the top slot to be cut to x8, and then split the “upper” x8 to x4x4 automatically for M2B and M2C. I know M2B is working with the SN630, but not M2C. So this is not really a surprise to me unless I’m misinterpreting that statement?

I assume this means that if I used a SATA M.2 SSD in the M2SB slot, which shouldn’t matter if I’m using an NVMe? Again, I might be misinterpreting.

Yes, that’s why I specifically went for the 11400 for my NAS instead of a 10100. The 11400 iirc is the lowest-end Rocket Lake SKU (I don’t think there are any RKL i3s), and should have all the IO features as any other RKL CPU I would assume?

Yeah, that’s kind of what I’m thinking, since M2A and others was clearly working with normal consumer-grade SSDs, however only M2B works with the SN630s :frowning: . Might mean that I should’ve gone for “normal” consumer-grade SSDs instead. Depending on how much $$$ I want to waste I might buy 4x cheap NVMe 256 GB SSDs just to see if it is an issue with the U.2 drives or if there’s something wonky with using all 4 slots at the same time, since I just don’t have really have any unused M.2 NVMes lying around atm for testing and don’t really want to waste a boat load of money on 4TB NVMes that may also not work. That’s also why I was wondering if anyone managed to use all the M.2 slots on this board, and what SSD they used.