Hard drive conflict with onboard SATA + LSI SAS/SATA card?

I’m having an issue using the onboard SATA controller on a AsRock ROMED8-2T motherboard with an LSI 9207-8i (SAS2308) controller card.

When hard drives are connected to both the LSI controller card and the motherboard controller:

  • The BIOS setup menu only shows the drives connected to the LSI controller.
  • The LSI controller menu shows the drives connected to it.
  • Linux only shows the drives connected to the motherboard controller.

When only the LSI controller is used and the motherboard SATA connections are disconnected:

  • The BIOS setup menu shows the drives connected to the LSI controller
  • The LSI controller menu shows the drives connected to it.
  • Linux shows the drives connected to LSI controller.

So the LSI kernel drivers are working properly. But there seems to be some kind of conflict with running both the LSI card and the motherboard SATA controller at the same time.

Perhaps it’s an ID issue, where the drives are being assigned #1-4 from LSI and the motherboard controller is also numbering it’s drives #1-4 so that both sets have the same numbers instead of being a single set of #1-8.

This has been tested on CentOS 8 and Debian 10.5 from a live cd. Same result.

I should also be able to see both sets of drives in the BIOS setup menu when working properly. Right now it’s only the LSI drives if both are plugged in, and only the onboard controller if the LSI controller is unplugged, in the same SATA slots (SATA0-SATA4) on the disk management tab.

Well, there’s your problem. It’s not Linux, it’s the BIOS. Try a different PCIe slot for the LSI card. You may need to manually set the IRQ numbers in the BIOS, if the option still exists that is.

I tried that as well. No change. I didn’t see an option for setting IRQ.

Is this a motherboard firmware issue then? There’s only SATA0-SATA7 in the bios menu. (It’s the menu where you can set each one to EFI or legacy boot mode).

If you have multiple LSI cards, that could easily be 16+ drives (each card takes 8). Is there any limit on motherboards that only allow 8 hard drives no matter how many cards you have? Or perhaps you can only choose from those eight options as boot options?

Have you seen the manual? Asrock offers a PDF here: https://download.asrock.com/Manual/ROMED8-2T.pdf

Read chapter 2.6 carefully, as there are jumpers enabling/disabling SATA ports.

It does not help with your board, but motherboards are not usually limited in drive numbers like that.
Even cheaper boards generally will allow all onboard sata slots to be populated and add-in-cards to add more drives.
Some boards have use less bandwidth for the data sockets, but in that case, you can use them all, but they get speed capped.

Are you intending to use the LSI in IT mode? Or did you make raid groups and pass them through?
I have not actually used the raid bit, but perhaps if the drives need to be initiated, that might be an issue?

Otherwise, maybe there is a UEFI option to set drives to RAID/AHCI mode. You might give that a go, even though you have not actually set any up?

Yes, I’ve read that and set them. It switches the speed of PCI slot two to enable/disable the onboard SATA.

The onboard SATA is enabled and works though, because I can see those drives in Linux.

What seems to be happening is some kind of IRQ conflict.

When I plug in only the LSI drives or only the motherboard drives, they work.

when I plug in both at once, the BIOS setup shows only the LSI drives, while Linux only shows the on board drives.

So maybe the BIOS menu and Linux initialize the drives in the opposite order, but since they have the same IDs, the second set gets ignored.

Yes, I believe it is in IT mode. I’m not sure this card has a hardware RAID option. There’s no battery on it. And nothing in the menu to suggest RAID. I was going to build a RAID 10 using MD.

Does LSI have any options for setting the IRQ manually?

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.