Hey Guys

I have some problems building a Hackintosh Laptop.

What I’ve got to get Mac OS

  • iMac (mid 2011)
  • USB stick

Where it should go:

I have more than 1 option but it should go on a notebook of some sorts

Possibilities are:

  • Asus R505CB (cpu i7 gen 3, gpu Nvidia)
  • HP G250 (cpu i5 gen 3, GPU Radeon)
  • HP ENVY (cpu i7 gen 4, gpu Nvidia)

would one of these machines work ?

I tried to do it like it is explained here https://www.tonymacx86.com/

I already have a problem downloading a macos version on my iMac as it can not run Catalina. It runs High Sierra. I don’t care what macos version my hackintosh would have, as it just has to run logic pro x

Is there a possibility to create a USB drive like described by https://www.tonymacx86.com/ just using a old mac and os? And how can this be done?

Or is there a way to get a working USB disk without having access to a newer mac?

i hope someone can help me

Thanks in advance


Need your chipset, GPU, and CPU models.

Asus (https://www.asus.com/Laptops/K56CB/specifications/)

Intel Core i7 3537U Processor (@2Ghz)
Intel HM76 Express Chipset
Nvidia GeForce GT740M / Intel HD Graphics 4000

this would be the best option.

if it dose not work i’ll check the other 2 notebooks

1 Like

The apple store only shows you the most current version available unless you’ve downloaded a previous version, then it would show under “purchased” apps. Fortunately the installers are still there, just hidden. Here’s some instruction that can work for most versions if you modify your search for Mojave or whatever.

1 Like

Catalina seems to be a bit of a mess still, at least for video editing. And of course it completely dropped 32bit applications.

Here are the official guides with included links to the hidden app store downloads for older versions of macOS. You can download those on any currently supported mac. So you probably can’t even download Catalina that way but I thought I throw it in the mix anyway.


Yeah should work fine.

Unsure about drivers?

Your DDT will likely want to deny this processor exists, but I think you can edit a file somewhere to get the processor to show in “About This Mac” and the hardware profiler.

Hackintoshing is pretty easy nowadays. You get a mac, get unibeast, make a usb, pack drivers if needed (you have nvidia, so bing bang bong I’m just unsure if the 740 specifically has support), and set up clover, then boot. Install, download multibeast, do the last of the driver setup and system config, and thats as far as you need to go for baseline. Theres a lot of other stuff you can do to get full system compatiblity, but thats strictly up to you and is detailed in a lot of other guides on how to do it on the tonymacx86 forums. DDST and SDST are the most annoying parts, but once they’re done they’re DONE.

If you need any other help during the process PM me or @ me here and I’ll try to assist.

Good luck!

1 Like


Thanks a lot for the help. I hope it will work :slight_smile: otherwise I would write again

1 Like


Now I was able to make a High Sierra bootable USB with UniBeast

If I plug it into the notebook it can boot to the UniBeast bootloader and I can choose install MacOS
Than it switches to a black screen with the Apple logo and a loadingbar appears. It loads for about 1% and than it is stuck there forever. I let the installation run overnight but it still hasn’t moved. Than I tried without injecting nvidia gaphics but that ended with the same result. I tried to find all the BIOS settings I was able to do the ones with the X i could not find the other ones.
X 1. Load Optimized Defaults
X 2. If your CPU supports VT-d , disable it
3. If your system has CFG-Lock , disable it
X 4. If your system has Secure Boot Mode , disable it
5. Set OS Type to Other OS
6. If your system has IO Serial Port , disable it
7. Set XHCI Handoff to Enabled

On the second try I went threw the BIOS disabling everything that I considered not needed like What happens when the lid gets closed,… wake on lan … and similar.

Did I forget something?

I read the thread https://www.tonymacx86.com/threads/first-hackintosh-stuck-at-the-apple-logo-screen.101945/
but I don’t have 2 Apple OS options in UniBeast.

I changed the CPU to a fake one (0x0506E3) like described here: https://www.reddit.com/r/hackintosh/comments/6i1p5b/stuck_at_apple_logo/

but now even the progress-bar is gone and it just reboots after showing the apple logo.

I googled some but did not find anything that worked for me, but then I am not sure what I am looking for :frowning:

Can’t really help with actual hackintoshing since I gave up on it.
Sorry. :man_shrugging:

1 Like

No it was loading fine the first time, it just legitimately hakes forever because it has to figure out why it isn’t seeing anythitg hardware wise during boot.

Keep screwing alound in bios. You coulda turned off somethitg you needed.

Also check out snazzy labs on youtube.

1 Like

first of all, from the clover boot menu, try selecting boot arguments and boot from -v (verbose mode) and see where its getting hung up.


As mentioned above, -v for verbose boot to see what’s happening and where it hangs. It will usually give you pretty good info, either an ACPI wait or what kext is crashing.
Also try booting with argument -no_compat_check
You should have the best luck on the HP laptop with a Radeon GPU or the Haswell laptop. Earlier Intel is not supported as well by macOS, because of the wimpy iGPU and lack of newer OpenGL support. GeForce 7xx seems to be the last nVidia gen to get decent support, but up to 10xx can work with 10.13 & web drivers. Obviously macOS :heart: Radeon the most though.

Thread closed as it was outside the guidelines for thread revival. Please PM me or another moderator if you feel the thread was closed in error. See the FAQ for more information.

Feel free to create a new thread if you wish to continue this thread’s conversation.