Return to Level1Techs.com

GPU acceleration on vmware Workstation running on POP!_os (AMD APU)

Hey there!

I’m newly sold on POP!_os, since it gave me such a good “out of the box” experience on various different systems. Now I ran into my first “real issue”:

POP!_os 20.10 (also tried 20.04 LTS) and
vmware Workstation 16
doesn’t support GPU-acceleration on my Ryzen 2400G “as is”.

All attempts to install different AMD-gpu drivers didn’t result in the “missing openGL” note from vmware Workstation.

Hope someone can bump me in the right direction or has a similar setup up and running?

LLAP :vulcan_salute:

Dumb question, but do you have Mesa installed?
Try running glxgears, if it gives you an error, try installing Mesa.

mesa-utils are installed now, but the opengl part was (as far as I have read) already installed. glxgears run fine.

But your question pushed me back again into the vmware-docs, where I found some hints:

Linux host operating system with a recent Intel/Vulkan driver is needed, Mesa 20.1 or later is recommended

The VMware guest operating system OpenGL driver for Windows and Linux supports the OpenGL 3.3 and OpenGL 4.1 core profile only. The compatibility profile is not supported.

Soooo… Mesa being only 19.1.7 is “not recommended” and the baked in OpenGL 4.5 is “Compatibility Profile”.

Trying to source the appropriate drivers for POP!_os 20.10 tomorrow (hopefully)

Thanks for giving me another angle :slight_smile:

Looks like System76 will be releasing an update in the near future for Linux 5.11 plus newer Mesa version to match.

1 Like

Yeah, my plans on continuing this project were definitely messed up, though, I’m just downloading the update, so messed up time schedule might just save me figuring this out :see_no_evil:

Will let you know in an hour or so, downloads are blazing fast :sweat_smile:

Edit: This does not compute (yet) and I think my statement about OpenGL4.5 working only in compatibility mode is just plain wrong, I was looking at the wrong tab, I think. However, after installment of the new update an another reboot to get vmware to modify the new kernel, it still says “no”…
Hopefully finding some spare time…