GnuTLS error : The request is invalid ( Lutris Battlefield 4 ) Solved!

I have been racking my head over this, to no avail. A little tired btw…

Fedora 29
In Lutris I click on “Show Logs” and get this error

GnuTLS error: The request is invalid.
GnuTLS error: The request is invalid.
GnuTLS error: The request is invalid.
Running /opt/wine-staging/bin/wine /home/vindican/Lutris_Games/drive_c/Program Files (x86)/Origin/OriginThinSetupInternal.exe
GnuTLS error: The request is invalid.

When I hit “Play” it blinks and comes back to this screen again.
I do have GnuTLS installed :

Package gnutls-3.6.5-2.fc29.x86_64 is already installed.
Package gnutls-3.6.5-2.fc29.i686 is already installed. 

Any help is greatly appreciated.

1 Like

Well I figured it out… Yup, currently playing BF4 on Linux. Who would’ve thought ! I will post here shortly how I resolved this issue and another that popped up while I was fixing this one.

1 Like

Well what a journey, but I got it all fixed and played through roughly 5 hours last night. So here’s what happened…

GnuTLS : The Fix

I removed the directory where Origin and Games resided in. Either through Lutris or my simply deleting the directory itself.


make sure that you have or the equivalent of your distro I am on Fedora 29:

gnutls-3.6.5-2.fc29.x86_64 , gnutls-3.6.5-2.fc29.i686

After a reinstall of the Origin app, I got the same error?! :man_shrugging:
This time I neded to see the logs to get more information. You can do this by starting Origin and then clicking the monitor icon on Lutris :


I found the following :

008a:err:winediag:SECUR32_initNTLMSP ntlm_auth was not found or is outdated. Make sure that ntlm_auth >= 3.0.25 is in your path. Usually, you can find it in the winbind package of your distribution.

It say’s ntlm_auth was not found, so I needed to get windbind , this is found in samba for Fedora 29.

samba-common-tools.x86_64 samba-libs.x86_64 samba-winbind.x86_64 samba-winbind-clients.x86_64 samba-winbind-modules.x86_64

Now ! surely I can get all this to work… right?! YUP ! it works.

After adding all these packages, do a clean reinstall of Origin, you can move your games to another directory in the meantime. Then you can game like a Pro ! ! ! !


Notable information:

I did this in a XFS partition, and allowing execution of files in that partition/directories as well. I had make those changes because I didn’t allow execution of files for “reasons”

1 Like

Not on topic but… can you play multiplayer on linux with BF4?

1 Like

I’ve played 8hrs since yesterday.

But you bring up a good point. Punkbuster needs to run and I had to do this through lutris.

1 Like

I was kicked from the first two online matches due to Punkbuster not running initially. So I did the following from Lutris:

run the punkbuster exec by navigating to the game ( battlefield 4 ) directory in my case it’s

/home/vindican/Lutris/drive_c/Program Files (x86)/Origin Games/Battlefield 4/pbsvc.exe

that is the punkbuster service. click through the prompts and you are good to go.

1 Like

You’re the best. :smiley:

1 Like

glad I can finally help you, you’ve helped a ton in the past ! :+1:

1 Like