GNOME Videos player not working

Hello world,

A part of my frustration on trying to love Linux.

Now, for some reason, I don’t know when this happened but I just few days ago noticed that the Videos preview app from the Gnome Software webstore just isn’t able to play my videos that I’ve had for half a year now that I’ve watched over and over. I tested videos that I filmed on different phones and also some that were downloaded. going back after starting a video and starting another one just freezes it
And this happens on the Videos (non beta) app too. So I moved the same videos on to a Windows machine and they worked perfectly fine. I ran all updates over pacman -Syu so all were up to date and updated all apps also. Restarted multiple times but the issue now still persists. Screenshots below.

Could this be the Intel Gpu driver breaking? (Maybe not because everything else works fine, even youtube videos)
So is it just the GNOME Apps that are broken again? (Can someone test)

I don’t use arch (but do use gnome). Only issues I run into are codec annoyances (non-free codecs that need to get installed separately). But here are some ideas:

  • can you try some other video players like VLC, mpv? Specifically with VLC there are a lot of options. Try with/without hardware accelleration.
  • can you run the video player from cli (the command is totem), and see if any debug messages pop up?
  • which codec do these videos use? did you install those on arch?

I was going through the Trashware and found HBud, it is what it is, but it actually played any video without issues. Although flipping the orientation. So, I guess GNOME app teams is just being GNOM app team again.

I was so scared that my data would be corrupt before I tried it on a different PC.

Kitty on zsh didn’t recognise totem. And I haven’t installed any additional on my accord.