GNOME Remote Desktop (rdp) w/o display

I am using a notebook where Manjaro is installed to perform various tasks for me. While usually I’m fine with just using ssh sometimes a display is required. Previously, I just connected via vnc to the machine but after a recent update wayland has been enabled and I have read rdp is the way to go.

Everything works fine, if the notebook’s display has been activated at least once, i.e. opening and closing the lid allows me to connect. However, if I do not open the lid - I use wakeonlan to power up the machine - rdp is unavle to connect.

Is it possible to have rdp activate the display somehow or do you know of a way that would enable me to comnect to the remote machine?

Any help or suggestions would be appreciated :blush:

1 Like

is switching to X11 an option you’re willing to entertain? i am unfamiliar with Wayland and its remote access capabilities, but i may be able to help you achieve this in an X11 environment.

1 Like

Sounds like you need to pipe the screen to rdp via pipewire. As for how, I have no idea. This page might help, or might not.


You might be able to get away with just configuring your output manually in your Xorg.conf.

Running a separate RDP server without a proper display output has some downsights like no hardware acceleration.

But if you just want to access a machine remotely with VNC or RDP you just need to install x11vnc or x11rdp and configure it.

Have you thought about just using ssh -Y to forward X11 applications? For a LAN, this is often the most convenient setup(requires no additional software and usually no additional configuration).

1 Like

What if it’s a gdm/lightgdm/login manager issue?

If one can connect from fresh boot, but not sleep, then see what state which service is? [Edit: issue is other way round, but still might be worth checking]

1 Like

I was using X11 in the past, but I figured I might give wayland a go

I have tried this in the past, but failed for some reason and it does also not work easily on Windows and Android.

How would I check and verify that?

My current - albeit less than ideal - solution is to not turn the computer off but suspend it. Unfortunately, even if I would be able to connect to the machine after a reboot, there still remains the issue where the password changes automatically after a reboot:

Unfortunately, there is also no option to disable password authentication…

1 Like

If you can SSH in, then check systemctl for any failed services?

1 Like

I think I have found the culprit:

Apr 06 10:56:37 cptLegendary gdm-autologin][857]: gkr-pam: couldn't unlock the login keyring.

It seems like not having a display connected is the problem, but much rather unlocking the keyring. So, either I have to set it to auto-unlock or I don reboot it and only do a systemctl suspend.

1 Like

so maybe a cheap-ish EDID display dongle thing.
welp, sorry if I led you down the wrong path

1 Like

Still would need to unlock the leychain, w/o this rdp is not possible. I consider this as fixed now and just use systemctl suspend for the time being.