Return to Level1Techs.com

[Gnome] Disable emoji keyboard shortcut (Ctrl+Shift+E)

Hello all,
I was using google docs when I tried to use the center text shortcut that had served me well on every other platform, but on gnome (F28) the shortcut would not work. I found out that it was some shortcut to type in an emoji. This is completely useless to me, and I would like to disable it. I found a forum post that suggested going into IBus Preferences ibus-setup and disable the shortcut there under the emoji tab. Screenshot:


Here the shortcut is disabled, but still pressing Ctrl+Shift+E creates the emoji prompt. Thanks for any help.

it’s gnome, so uh

dont use it

@Eden uses Gnome. He’s from the UK tho. So it’ll be a while for him to respond.

Added ‘helpdesk’ tag so people know you need help.

Did you look in the keyboard section of the settings app or the tweaks app? You can set hotkeys and shortcuts in those apps.

That’s not helpful what so ever.

I’ll have a look at this later if no one has an answer as it probably affects me

Open dconf editor and navigate to org.freedesktop.ibus.panel.emoji. Then change the hotkey field to []


This is the GNOME equivalent of “JUST USE LINUX!”. You are not helping anyone and only make the forum more toxic than necessary. If you don’t like GNOME don’t use it and ignore the related threads.

4 Likes

It’s just my experience that mutter plugins tend to be pretty inflexible black boxes for input stuff like this, especially on wayland.

For example, you have to modprobe out your touch device driver entirely if your calibration drifts off even a little on laptops with touchscreens on wayland systems.

GNOME is far from perfect. But here is a person who is using GNOME and wants a problem solved. Telling people to just use something different because you don’t like it is childish and doesn’t solve problems. Every other DE has their own set of problems.

2 Likes

i mean it would have solved the emoji input problem

baffling they’d assign those to universal hotkeys in the first place tbh

I don’t have that option. Its not there.

Odd. You can try running

gsettings set org.freedesktop.ibus.panel.emoji hotkey []

But I suspect it’ll give you an error because the key doesn’t exist for you.

1 Like

No error, but it didn’t do anything. (I had to escape the brackets for zsh)

╭─[email protected] ~ 
╰─ ➜ $ gsettings set org.freedesktop.ibus.panel.emoji hotkey \[\]
╭─[email protected] ~ 
╰─ ➜ $ echo $?
0

Here is a possible solution (it is not a perfect solution, i think the issue is a bug, this is a workaround)

Open settings > Region & Language

Add a new input source > select the three dots

image

Search for booster, you will have the option of other select this.

Select Other (Typing Booster)

This will have a gear icon, you can edit the settings to your wishes (typing booster has perdition etc. you might not want this or want to change how it works).

On the top right select the “en” icon and select Other (Typing Booster)

Your short cut will now work as expected.

Typing booster is pretty cool, you might like it, but if you don’t you can turn a lot of the features off. If you set Enable suggestions by Tab key you will not get automatic suggestions.

More info on typing booster here: https://mike-fabian.github.io/ibus-typing-booster/documentation.html

Can someone tell me how that shortcut works? I know ctrl+shift+u for unicode and ctrl+. for the emoji chooser. Do i need to know the exact emoji name for this shortcut?

Sorry for offtopic. But i guess it helps to know that you can input emojis via ctrl+. if you disabled ctrl+shift+e. :slight_smile:

oh hey looks like the input options were totally broken and inflexible

don’t mind me though

OP,

Did you look in Gnome Tweaks or the Gnome Settings apps for the keyboatd shortcuts. Usually you would make you changes there.

Thank you, this worked wonders!

On Ubuntu 18.10, executed it with sudo and without sudo.

I needed this shortcut because VSCode.

I realize this topic is hella old but I’d just like to point out this issue still exists (Ubuntu 19.04, 3.32.1). In case anyone knows, is there an update to some software package that fixes this yet?