GNOME 3.38 - Xorg: 144Hz won't work with multiple monitors on AMD

Shadow holder had already mentioned this: GNOME 3.38 - Xorg: 144Hz won't work with multiple monitors on AMD

I have gotten this working correctly on X before. It should be possible.

Unless the nvidia driver is doing some black magic to make it possible.

I def see this. If I run a game as not fullscreen it tends to tear and ‘feels’ slower.

My point was that you can have multiple refresh settings on different screens with an AMD card.

I know that if I have one at 24, one at 52 and one at 60, the one at 24 looks terrible.

Yeah, I’m not sold on this being an X issue or an AMD issue. I have a hard time believing nvidia is capable of this and AMD is not but I dont have any way to prove it.

It could be some NV black magic. Remember that they supported multiple screens at different resolutions before xRandr became a thing. And then when xRandr became the default, the NV stuff broke.

not saying that X and AMD (and Intel) are not capable of doing it, but that NV’s user space has a lot of secret sauce.

Sorry I haven’t replied to this in a while I’ve been busy with other things. As far as the different refresh rates issue goes it seems this problem does also occur on NVIDIA but there are fixes when using environmental variables and NVIDIA settings app. Sadly no such fixes are available for AMD so I have resorted to using Wayland which is mostly fine with just a few small annoyances.

Regarding the mouse freezing/USB issue I mentioned earlier I’m now fairly certain that it’s actually a problem related to newer kernel versions. I figured this out by running a series of mkinitcpio commands on different kernel versions newer linux and linux-zen kernels warned about missing xhci_pci modules while the older linux-lts kernel did not display any such warning. I’ve linked the results of these commands here. On top of this I don’t believe I have actually ever experienced this issue on linux-lts as at the time I thought it was a Wayland issue and switched my kernel to linux-zen. I also never used to have this issue on older arch installs. Sadly I cannot test this theory in the real world right now as before I realized this I made an oopsie and accidentally wiped my SSD and installed Pop_OS instead of Arch. Next time I reinstall I will reply back with the results.

However even if my theory is correct it is still not an ideal solution because:

  1. I want a newer kernel with fsync patches provided by linux-zen
  2. At some point when the linux-lts kernel gets updated enough the same issue that caused this in newer version is bound to crop up in LTS as well

I would be grateful if somebody could suggest a more permanent fix. My motherboard is an MSI B450 Tomahawk MAX with an AMD Ryzen 5 3600 installed using the AM4 chipset. Most of the ports on the back of the computer are also USB 3.1.

Also I will probably start a separate thread for this issue soon as it is off topic from the original issue.

Do you have legacy USB mode turned on in your BIOS? I had this issue on AM3+ and the solution was to turn that off in BIOS and ensure that UNPN aware OS was turned on.

Thanks I will try turning that off. Slightly annoying because I will have to turn it back on if I want to boot from a USB but a small price to pay if it fixes the issue :grinning:

Edit: What is UNPN aware OS?

Universal plug and play.

Also, if you turn off legacy USB support, you should still be fine. The legacy is a hardware work around for some hardware and some MS Windows drivers. the XHCI and UHCI USB interfaces/protocols should handle the legacy devices fine.

Ah okay my bios doesn’t have an option f unpn but its almost certainly on by default. I have not had anymore issues since turning off legacy usb but its an intermittent problem so I’ll have to wait and see :slight_smile:

Good luck. I hope you see no more hick-ups.

Thanks me too. Another interesting thing a found while testing in a arch vm is that installing the upd72020x-fw package fixed the xhci_pci warning even though I don’t believe I have a Renesas USB card unless it’s integrated into the motherboard.

Damn I just got another freeze in Pop_OS. I might back up this installation and try to install arch with the upd72020x-fw package and see how that goes

I’m marking this as solved now as I doubt anything more can be contributed to the original topic. I will probably start a second thread for the USB issue. Thanks for everybody’s help :slight_smile:

3 Likes

This is a very important issue for myself also. Although not sure at this point what would be the best solution! Got an NVIDIA gpu.

I don’t have a Nvidia card so it’s a little hard for me to give you good answers but try adding the following to your /etc/environment file:

  • CLUTTER_DEFAULT_FPS=RefreshRate
  • __GL_SYNC_DISPLAY_DEVICE=Output

Replacing RefreshRate and Output with the refresh rate of your monitor and the name of the output port for your high refresh rate monitor (find using xrandr)

I think there is also something about disabling flipping in the Nvidia settings but I can’t find where I read that sadly so just try and poke around in the nvidia settings and see if you can find anything related to disabling flipping.

Note: Make sure to reboot after both the changes to /etc/environment and after changes to nvidia settings.

Hope this helps :slight_smile:

Make a thread of your own. The solution is simple really but I don’t want to hijack this one.

Edit: Ugh, sorry for a semi-necro bump, I did not notice this was more than a month old

Just to add my 2cents:
I am running AMD R9 390 with amdgpu driver with xfce. (no wayland)
Per-monitor refresh rates work. I have 2 4k monitors connected but unfortunately this card can do [email protected] only with DP, the second monitor is connected to HDMI running [email protected]
It is super-noticeable.
I see the difference wile moving a cursor, windows, playing videos, running UFO test, etc. This is both with or without compositor enabled.

the only non-default/non-automatic X-config I have is this:

/etc/X11/xorg.conf.d/20-amdgpu.conf
Section "Device"
	Identifier "AMD"
	Driver "amdgpu"
	Option "TearFree" "true"
EndSection

my current kernel is 5.7.11-arch

So I would agree that this is not an intrinsic X or AMD issue.
misconfiguration/distro/gnome fault is more likely.

2 Likes

its alright if its pertinent to a solution.

Semi necro bumps welcome! (but full necro bump is better, of course)