Return to Level1Techs.com

Gaming help on Linux

ubuntu
helpdesk
#1

Hi everyone. I have a Ubuntu 18.04 box with a Radeon VII, AMD 1600, and 16 GB of memory. In the last several weeks, my box stopped running XCOM2. But still runs XCOM: Enemy Unknown. I reinstalled the AMD Radeon Pro drivers. I installed kernel Linux 5.2.3-050203-generic. Can I get some advise on how to troubleshoot this issue?

Related, this is a multi-purpose box. And isn’t a dedicated gaming machine.

Also, why would one game work and not the other one?

Last, I don’t get a correct MESA version. For example:

glxinfo | grep “OpenGL version”
OpenGL version string: 4.613556 Compatibility Profile Context

I should probably see something more like the following:
image

0 Likes

#2

I would say to try the open source AMD driver. The pro driver has a few games that It can cause problems with.

2 Likes

#3

Yeah, from everything i ever read on AMD under Linux: You never need the Pro driver, unless you are running FirePro GPU’s to do rendering or such.
For anything else, just never install drivers and you should be good.

1 Like

#4

OP,

You mentioned that it is not a dedicated rig. What else does it do? You can hybrid install the Pro driver with parts of the opensource stack. If you do not need the Pro stack just use the opensource driver. If you need OpenCL or other compute components, then hybrid install or run ROCm.

https://wiki.archlinux.org/index.php/AMDGPU#Installation

0 Likes

#5

If the problem persists, you could try launching XCOM through the terminal (if possible), to get a more helpful error log.

1 Like

#6

Thank you so much. I installed the latest AMD-Open driver and it worked! Thank you Thank you Thank you Thank you. I want to say I tried the Open driver and it didn’t work las year. But maybe I am more confused that I think I am.

2 Likes

#7

That’s a question that is embarrassing to answer.

It’s kind of a game server using Steam Remote Play.
It’s kind of a VM host by running KVM.
It’s kind of a storage host by having an LSI HBA flashed to IT Mode and a bunch of drives.

It’s a work in progress, but that’s what I’ve got planned so far. The VMs include PfSense, Emby, and I’m working on FreeIPA.

What do you think?

0 Likes

#8

Not embarrassing at all. Not all of us have the monies to make dedicated rigs for all of our interests. You sound like most of us.

I was asking that question in case you were doing machine learning or the like. I could help you figure out the hybrid install if you need the pro drivers for OpenCL or TensorFlow, and etc.

I m glad the open drivers work for you.

0 Likes

#9

Thanks. That’s surprising you mention the open drivers. My box just crashed. It wasn’t a problem with the pro drivers. I’m about to open a ticket with AMD support. Do you have any recommendations about troubleshooting the open driver?

https://bugs.freedesktop.org/show_bug.cgi?id=111287

0 Likes

#10

You need to pull logs to figure out what the system is complaining about. Also you need to provide a description of what you were doing when it happened.

You want to write dmesg to a file sudo dmesg > /path/to/your/home/dmesg.log and you want to look at journalctl to see what happened in the last boot (when the issue occured). https://wiki.archlinux.org/index.php/Systemd/Journal.

Essentially you need to provide some context to the issue. We and/or AMD will need something to look at. Your hardware is still bleeding edge in regards to the *nix world and the drivers are still a work in progress so you may be running into corner cases that can help improve the usage of all VII users on *nix. Happy hunting!

If you did a fresh install of Ubuntu like you said, it could be possible that you are missing the newest firmware needed for the kernel 5.2 that you have installed.

Could you do the following and see what you get as well, sudo apt show firmware-linux
Which version are you showing? If you do not show it as manual installed, go ahead and run sudo apt update && sudo apt install linux-firmware

0 Likes

#11

Sounds good. I appreciate it. It looks like I need to file a bug report with Gnome to pickup where this guy left off: https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1831343

Does it make sense to try to downgrade GTK 3?
https://bbs.archlinux.org/viewtopic.php?id=245097dmesg.txt (85.0 KB)

It looks like there isn’t anything to do with the firmware. I have a ASRock AB350 Pro4 AM4 AMD Promontory B350 SATA 6Gb/s USB 3.1 HDMI ATX AMD Motherboard. I got it because of the recommendations from Phoronix. https://www.phoronix.com/scan.php?page=article&item=asrock-ab350-pro4&num=1

I’m srprised to see they don’t have anything besides Windows 7/10 support listed on the ASRock website.

$ sudo apt show firmware-linux
Package: firmware-linux
State: not a real package (virtual)
N: Can’t select candidate version from package firmware-linux as it has no candidate
N: Can’t select versions from package ‘firmware-linux’ as it is purely virtual
N: No packages found

$ sudo apt update && sudo apt install linux-firmware
Hit:1 http://repo.steampowered.com/steam precise InRelease
Get:2 http://security.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
Hit:3 http://ppa.launchpad.net/teejee2008/ppa/ubuntu bionic InRelease
Hit:4 http://us.archive.ubuntu.com/ubuntu bionic InRelease
Get:5 http://us.archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
Hit:6 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic InRelease
Get:7 http://us.archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
Get:8 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages [696 kB]
Get:9 http://us.archive.ubuntu.com/ubuntu bionic-updates/main i386 Packages [565 kB]
Get:10 http://us.archive.ubuntu.com/ubuntu bionic-updates/main amd64 DEP-11 Metadata [282 kB]
Get:11 http://us.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 48x48 Icons [66.6 kB]
Get:12 http://us.archive.ubuntu.com/ubuntu bionic-updates/main DEP-11 64x64 Icons [134 kB]
Get:13 http://us.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages [980 kB]
Get:14 http://us.archive.ubuntu.com/ubuntu bionic-updates/universe i386 Packages [962 kB]
Get:15 http://us.archive.ubuntu.com/ubuntu bionic-updates/universe amd64 DEP-11 Metadata [251 kB]
Get:16 http://us.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 48x48 Icons [209 kB]
Get:17 http://us.archive.ubuntu.com/ubuntu bionic-updates/universe DEP-11 64x64 Icons [437 kB]
Get:18 http://us.archive.ubuntu.com/ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2,468 B]
Get:19 http://us.archive.ubuntu.com/ubuntu bionic-backports/universe amd64 DEP-11 Metadata [7,708 B]
Get:20 http://security.ubuntu.com/ubuntu bionic-security/main amd64 DEP-11 Metadata [22.7 kB]
Get:21 http://security.ubuntu.com/ubuntu bionic-security/main DEP-11 64x64 Icons [31.7 kB]
Get:22 http://security.ubuntu.com/ubuntu bionic-security/universe amd64 DEP-11 Metadata [42.1 kB]
Get:23 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 48x48 Icons [16.4 kB]
Get:24 http://security.ubuntu.com/ubuntu bionic-security/universe DEP-11 64x64 Icons [116 kB]
Get:25 http://security.ubuntu.com/ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2,464 B]
Fetched 5,077 kB in 2s (3,382 kB/s)
Reading package lists… Done
Building dependency tree
Reading state information… Done
All packages are up to date.
Reading package lists… Done
Building dependency tree
Reading state information… Done
linux-firmware is already the newest version (1.173.9).
linux-firmware set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

$ sudo apt show firmware-linux
Package: firmware-linux
State: not a real package (virtual)
N: Can’t select candidate version from package firmware-linux as it has no candidate
N: Can’t select versions from package ‘firmware-linux’ as it is purely virtual
N: No packages found

CRITICAL: We failed, but the fail whale is dead. Sorry…
PRIORITY 2
SYSLOG_FACILITY 3
SYSLOG_IDENTIFIER gnome-session-binary
SYSLOG_PID 1603
_AUDIT_LOGINUID 1000
_AUDIT_SESSION 2
_BOOT_ID 56708a8042564d1e890ce22433ece4f0
_CAP_EFFECTIVE 0
_CMDLINE /usr/lib/gnome-session/gnome-session-binary --session=ubuntu
_COMM gnome-session-b
_EXE /usr/lib/gnome-session/gnome-session-binary
_GID 1000
_HOSTNAME STN-KVM-01
_MACHINE_ID cafa1885becc49638245632088366c60
_PID 1603
_SELINUX_CONTEXT unconfined
_SOURCE_REALTIME_TIMESTAMP 1564761479880714
_SYSTEMD_CGROUP /user.slice/user-1000.slice/session-2.scope
_SYSTEMD_INVOCATION_ID ab8b37f0ae9f496bab68a33337efd3ad
_SYSTEMD_OWNER_UID 1000
_SYSTEMD_SESSION 2
_SYSTEMD_SLICE user-1000.slice
_SYSTEMD_UNIT session-2.scope
_SYSTEMD_USER_SLICE -.slice
_TRANSPORT syslog
_UID 1000
__CURSOR s=443f5f7169cf4f74bc54f513a2c91409;i=41dd7;b=56708a8042564d1e890ce22433ece4f0;m=133a3f9;t=58f246c2aa1be;x=b35ba2467b9cfd6c
__MONOTONIC_TIMESTAMP 20161529
__REALTIME_TIMESTAMP 1564761479881150

Unrecoverable failure in required component org.gnome.Shell.desktop
CODE_FILE …/gnome-session/gsm-manager.c
CODE_FUNC on_display_server_failure
CODE_LINE 308
MESSAGE_ID 10dd2dc188b54a5e98970f56499d1f73
PRIORITY 3
SYSLOG_IDENTIFIER gnome-session-binary
_BOOT_ID 56708a8042564d1e890ce22433ece4f0
_CAP_EFFECTIVE 0
_CMDLINE /usr/lib/gnome-session/gnome-session-binary --autostart /usr/share/gdm/greeter/autostart
_COMM gnome-session-b
_EXE /usr/lib/gnome-session/gnome-session-binary
_GID 125
_MACHINE_ID cafa1885becc49638245632088366c60
_PID 2561
_SELINUX_CONTEXT unconfined
_SOURCE_REALTIME_TIMESTAMP 1564761480862609
_SYSTEMD_CGROUP /user.slice/user-121.slice/session-c1.scope
_SYSTEMD_INVOCATION_ID 8bb53cf883c9446996b6e1da9dbe7ed0
_SYSTEMD_OWNER_UID 121
_SYSTEMD_SESSION c1
_SYSTEMD_SLICE user-121.slice
_SYSTEMD_UNIT session-c1.scope
_SYSTEMD_USER_SLICE -.slice
_TRANSPORT journal
_UID 121

0 Likes

#12

I am a Debian SID and ArchLinux user. Ubuntu is Debian based and used apt. I am surprised that Ubuntu apt is not able to list details about virtual packages.

In regards to firmware, I meant the firmware for the gpu. You CPU and GPU run microcode that is updated in the linux-firmware-* packages. If your kernel is too new or the mesa package is too new and invokes routines or expects results that the currently loaded firmware does not work with, it can cause issues. The firmware is usually packages in the kernel sources so I would assume that whoever built your kernel packaged that as well. I am out of ideas on that.

You could be very well having an ubuntu specific issue as last year is when they officially switched over to gnome3 and wayland from unity and mir. As Canonical tends to do, they were doing things their own way instead of just repackaging the debian binaries and have run into issues with gnome3 and wayland. I would add my issues to that person’s bug report.

0 Likes