Games lag (Overwatch) on Arch Linux

I have installed nvidia, nvidia-utils, and nvidia-settings. i am using Arch Linux with KDE plasma, this is a fresh install so everything is up to date. I am trying to play games through steam, primarily overwatch, but this issue is happening with most games I launch with the exception of stardew valley. It takes forever to launch and just chugs at the menu screen, I am unable to hit any buttons without a 30 second delay. I have an RTX 3080 and intel 12700k. How can I get good performance on overwatch through steam? I am currently playing around with proton versions and perhaps trying lutris instead.

That’s how it works. When you open the game it starts compiling the shaders from shader cache and that results in quite a bit of lag until that is done. Overwatch in particular comes with a massive amount of shaders that need to be compiled. Typically subsequent launches should be smoother as the shader cache fills up.
You can enable the DXVK HUD to see when it’s processing shaders:


Enable background processing of Vulkan shaders (Steam settings menu, Downloads)…with a config file you can also tune the amount of cores used. Works really well.


a steam config file? or for overwatch specifically? and did you mean the amount of cores used for background processing or for overwatch?

I’m talking about Steam and the Vulkan shader pre-processing. You either have to wait at startup or do this in the background when not playing.

Steam cuts all processes if something is running, because 16 cores of load isn’t a good thing when playing.

1 Like