Game disconnects when out-of-focus - a very Fedora KDE problem

I play a non-Steam game. (World of Warships to be exact). It runs fine on wine, no problem with gaming.

I have two computers, both running Fedora 36 that I run the same game on:

  1. Gnome DE, intel i7-8700K, AMD 5700XT, 32 GB RAM
  2. KDE DE, AMD 5600G, Nvidia 1080 Ti, 32 GB RAM

On Gnome, I run fixed number of workspaces (4) and i run the game on the 4th.
On KDE, I prefer virtual desktops, again 4, and i run the game on the 4th.

However on the KDE machine, if I switch to any other virtual desktop, the game’s network connection drops. Here’s how I noticed: If i’m in an active combat, if i switch to another VD and switch back immediately, the game acts as if it experienced a sudden lag spike and it tries catching up. If I delay in switching back, it disconnects. If i sit in the game in the port (ie the game lobby), it doesn’t do much networking so it’ll sit there for a much longer time but it also will disconnect if I stay off the game for too long. No disconnects or any other problem while actually playing the game, zero problems playing.

This does NOT happen when running on Gnome. I can switch to another workspace for an hour and nothing will happen to the game.

Now you might be thinking, this is a KDE problem, but also no. Because I also have a Manjaro KDE setup (dual boot), also running wayland, on the same Fedora KDE machine and there’s absolutely no disconnects when switching VDs.

I’m at a loss as to what’s causing this or even where to look to start troubleshooting.

Any ideas?

WoWS is on steam - while it doesnt address your issue directly, have you tried running it thorugh steam to see if that fixes it?

Also - double check that Fedora doesnt have any wifi or network power saving stuff turned on that kills the connection once its not the active window