Return to Level1Techs.com

G-sync causing display signal loss on Linux

I am using Fedora 32 and the 440.82 Nvidia driver on a GTX 1070.
My display is the ASUS VG27AQ, which is certified GSYNC-compatible (Freesync).
Kernel version: 5.6.16-300.fc32.x86_64
GNOME 3.36

Whenever I boot up my PC and use GSYNC it works fine. However, as soon as I lock the screen and the monitor turns off, and then I turn it back on again, GSYNC will be “broken”: as soon as I launch a fullscreen game/video, my monitor says “No input” until I alt-tab or close the application. I can fix this by logging out and back into my session.

Here is an example of the issue I am having: https://www.youtube.com/watch?v=q6-i82U64cc

There is also a thread on the Nvidia dev forum, but it doesn’t have any helpful answers, so I was wondering if anyone here could help?

Any help is much appreciated.

Going to sleep or hibernate is always a bad idea on Nvidia Proprietary drivers. You’ll end up with scrambled framebuffers until a cold boot fixes it.

Also, signal drop happens when the monitor assumes a fixed refresh then it’s actually variable refresh. Rebooting the monitor fixes this sometimes, and I often get this switching outputs from my first PC to my second PC, both Freesync enabled. I had to reboot the monitor.

440.82 is also considered by Ubuntu an unstable driver.

The problem is that rebooting the monitor is exactly what causes the issue. My computer is set to never go to sleep/hibernate, but the issue happens when the monitor is turned off and then on again. The only way to fix it is to restart the GNOME session, either by logging out and back in or by rebooting.

Sounds like your monitor stops sending consistent EDID when switching inputs or when you shut off the monitor. My best suggestion is to get something inbetween that stores your monitor EDID and prevents the EDID from disconnecting with the GPU. You’ll have to find a DP 1.4 compatible EDID emulator, and unfortunately, it’s only really present in high end KVM switches.

Yeah the whole gsync compatible thing is a bit broken under Linux sorry to say.

If you go buy a genuine gsync monitor your problems will probably disappear, or run windows.

I tried to fix the issue with custom EDID but it only made it worse, just seems Linux is just not ready for G-SYNC Compatible monitor usage.

Might get a AMD GPU if they are decent enough. (using 1080ti atm)

You could try with the EDID Ghost/Splitter on the Level1Store. This might be better than modifying the EDID: