Return to Level1Techs.com

Freenas with Direct connection

Hi, I’m trying to set up a Nas server with FreeNAS that is directly connected to my desktop with an ethernet cable as I won’t be able to have it over the network for some time and so far I’ve installed FreeNAS however I can’t get the network interface to show via the windows machine. I really have no idea how to set up the networking side with FreeNAS I haven’t worked with this sorta thing that much so as detailed and step by step as it can be would be helpful. thanks for all the suggestions I’m sure to have soon.

setting this isn’t hard if you know a bit about network, but if you have 0 knowledge it might be tricky.

What do you mean by “I can’t get the network interface to show via the windows machine”

Do you have multiple ethernet port, and use one for the nas ?
Do you have a single ethenet port and use wifi for internet ?

so I currently have one Ethernet port on my pc that I want to use for the nas, I plan to buy an Ethernet jack or upgrade the mobo in the future for another. then use the WiFi for internet on my PC

Do you have 2 NICs on your main PC? This will be fairly easy, as you’ll just need to set the FreeNAS IP address of it’s primary NIC and have the spare port on your PC set to use an IP addresses within the same subnet. Example:

FreeNAS:
IP: 192.168.1.100
Subnet: 255.255.255.0
Gateway: 192.168.1.1 (The gateway can be unset in a direct connect scenario)

PC Spare NIC:
IP: 192.168.1.200
Subnet: 255.255.255.0
Gateway: 192.168.1.1 or blank

i only have wireless and one Ethernet port on the main PC

Gotcha. Also, I forgot to mention, make sure that both ports on your PC are on different subnets/networks. Example being the FreeNAS direct connection would be 192.168.1.0 network and the wireless would be 10.0.0.0 network or something. You can check the current IP configuration of all your network devices by opening either a command prompt or powershell and typing ipconfig

Posting screenshots will also help

here is the ipconfig for my main pc

first you need to setup a manual ethernet nework on your computer, look here for howto : https://support.microsoft.com/en-ph/help/15089/windows-change-tcp-ip-settings
i’ll recommend setting up a 10.0.1.0/24 network (don’t ask why this one, i like it better :stuck_out_tongue: ) with your computer as 10.0.1.2 and your Freenas as 10.0.1.1 (since it’s the main thingy ?)
once your Windows ethernet set up, it should show up in ipconfig.
then setup freenas network (use this : https://youtu.be/_cvI29866NI?t=157 ) with the address up above :slight_smile:
once this is done, you should be able to ping freenas ip from windows.

i seem to have it all setup and working now thank you

new issue immediately arose. so ive setup an smb share and enabled the service however my win 10 machine cannot see the share. ive given guest access to the share as well.

You need to have the service running.

the service is indeed running

Open File Explorer in windows and try typing \\<FreeNAS_IP>\<Share_Name>

and see if you can connect to it

Example: \\10.0.0.1\MyShare

in the process of moving ill test that in a day or so and let you know what happens

1 Like