FreeNAS 11.0 U2 server dead?

I’ll cut straight to the chase: my FreeNAS 11.0 U2 server refuses to boot from either of my USB boot devices.

Story: I tried turning on my server so I can try to get the Web GUI working with HTTPS, but it kept looping in the BIOS (i.e. it kept resetting itself without booting into FreeNAS). I switched to my second USB device which I used to make a copy of the instillation via attaching it to the boot device and it worked fine. I, however, wanted to diagnose the problem and took out the backup that worked and replaced it with the initial boot device. Again, it refused to boot in its original USB port and in the port where the backup was plugged in. I took the initial boot device out and plugged in the backup in its original port and it worked fine. I tried plugging in the backup into the initial boot device’s port, but it failed. Now both refuse to boot at all!

I don’t believe that either USB ports are at fault since they both booted Linux Mint 18.2 on a third USB device just fine. The drive also worked afterwords when plugged into my laptop and gaming PC. Furthermore, the two USB boot devices are detected albeit I can’t open them since windows wants me to format them.

So in short:

  1. What the hell is wrong?
  2. How can I fix it?
  3. If a fresh install is necessary, then how do I recover my data and SMB share settings/users/groups?

Thanks for any and all help

It sounds like the flash drives had some bad spots in them. Flash drives are not sufficient for storing data long term and even more so backups. Flash still decays just like hard drives do; certain kinds, not all are created equal.

If you just used run of the mill flash drives then likely your FreeNAS is borked. As long as your backup isn’t also borked then you should be okay but you need to invest in actually good backup devices, or at least an offsite backup to recover from these kinds of situations.

ZFS is on the pool where your data is, that data is fine. Just import the pool into a new FreeNAS installation.

Again, it all should transfer over from the storage pool, as long as your stored it there.

What Dynamic_Gravity said, just put FreeNAS on a new USB and away you go, if you want redundancy, you can mirror the USB’s so if one fails, the other will pick up the slack, just remember to keep an eye for the health of your storage devices in case you need to replace them.

Thanks Dynamic_Gravity!

Sorry I took long to respond. I became busy and I couldn’t work on my NAS until today. Installing FreeNAS on a new USB stick worked fine and I was able to access my data again!

If you don’t mind me asking, how much would a better backup solution be compared to a couple of USB sticks? I’m just a college student so USB sticks is the best I could do for now. Hell, I wish I could have an offsite backup and a pfSense box!

Hey shu_kaze!

I did mirror the USBs, but the backup failed as well for some reason. Both had been in use for less than a week which I found strange. Thursday, August 17 was the last day I used my NAS before it refused to boot on Saturday, August 19. I used Rufus to check and see if the sticks had any read or write errors, but none came up.

Here’s hoping my new USB sticks don’t fail in the same time span!

Welp, I spoke too soon. I’ve managed to recreate the problem again. After getting everything up and running, I mirrored my USBs the exact same way as I did the first time and got the same exact problem. My system refuses to boot into FreeNAS and instead loops the BIOS startup. Would this problem arise from the way I mirror my USBs or from FreeNAS 11.0 itself?

I also took a screenshot a minute after mirroring my USBs because I got a critical system alert that disappeared after a handful of minutes or so. The pic is below:

EDIT: I use the same mirroring method used by this guy for my FreeNAS installation:

I don’t consider USB drives reliable enough to store FreeNAS on. Not even sure why they recommend it. They usually are not big enough and can disconnect pretty easily. It seems your BIOS is dropping them after a disconnection or some other kind of failure. You would be better served using almost any old HDD that is functioning well. Pull one out of an old laptop or something like that.
FreeNAS doesn’t really seem to benefit from running from an SSD, still takes quite a while to boot. So no real need to fork out for one.

There any many backup solutions, such as external HDDs. All have a chance of being trashed for various reasons. FreeNAS + ZFS is the best for data integrity. If you absolutely do not want the data to degrade over time, it is a good choice. I.e. family pictures, important stuff.
If you just want to store stuff that can be replaced, such as general media for consumption, any other solution will work fine such as external HDDs.,

Hell, if you don’t mind using drop box or services like that, knowing where the data will be, that will work too.

I am also a college student so I feel the pain. However, ADATA SSD’s are my usually choice for cheap low storage SSD’s to just be used as boot drives. They perform handsomely and you won’t run into issues like you are with these flash drives.

FreeNAS running from USB are practically solid since your not doing much on them thus very little writes on them, most of the write operations are on your storage media such as HDD’s (or if your ambitious, SSD) and also caching on SSD.

This may be late, but I would recommend looking at what brand and type of usb your using, since there are dodgy and low quality ones out there even in the general market. For me I trust no other than corsair, kingston or sandisk since they’ve never failed me before and in fact their still running on my NAS for about 43 months now: Click to know

16GB is more than enough to store FreeNAS on and it’s not even taking half of it’s storage on them.