Return to Level1Techs.com

Flashing c930c with c930e firmware?

Ok so I got a Logitech c930 because of “the thing.” But here is the deal, it is a c930c not a c930e. From what I can tell the only difference is serial number and the language. But because having Chinese characters in my device manager messes with my OCD and because I’m slightly paranoid that China is going to listen in on my Zoom meetings. I wanted to know if there was a way to flash the c930e firmware onto the c930c. I already tired the automated firmware flash tool from Logitech. It just tells me device not found. I’m guessing I’ll have to do some Linux-foo or something. Anyway, i figured there was probably someone on here who was bored enough to try and help.

tl;dr

Anyone want to spend their #Quarantine2020 helping me flash c930c with c930e firmware?

I also bought a C930c due to the thing. Does c stand for China or Corona?

As far as I can tell it operates identically to the e model. The only issue I have discovered so far is Logitech Capture doesn’t recognize the camera.

Stands for Compromised, as in they’re spying on you with it. xD


Real talk, it’s probably just set up to be on some sort of Chinese approved parts stuff. They do funny stuff with cryptography, so if the camera supports any inbuilt encryption, it’s probably broken.

what do you mean by inbuilt encryption?

I am in the same boat. Nice webcam, but the Chinese menus, etc. worry me. Also, apparently C stands for Chinese (i.e. the language), and is supposedly identical, but who the heck knows what else is in the firmware.

I might watch the traffic in use, but hey, Zoom shares with China anyhow, so there is that. But with Mattermost or some other app, I’d like to know there wasn’t a built-in man-in-the-middle in the firmware. Plus the C930c might not show up on some programs.

Anyhow, while this isn’t the right moment in history to risk bricking a webcam, I will certainly be trying to turn mine into a proper C930e. If I succeed (or if I brick it!) I’ll update this thread.

1 Like

Hi Guys,

Same situation here. I want to reflash my c930c with the 930e firmware. Not worried about any MIDM but want to get rid of the Chinese device id in Windows and be able to use all of the tools.

I guess first I’d need to check if the USB id’s are different (what’s the USB id for the 930e?) and if they are how to fake it for the time of the fw upgrade.

Hi all,
I am in the same situation. Please can share if we can turn our c930c into an e.

Thanks.

Ditto.
Shame if it can’t be flashed. I’d prefer to see EN characters etc too.

Same here, I’d be very interested in flashing the device with C930e firmware.

I am on this boat too… just got mine today… saved $100 AUD over a 930E but its becoming maybe an issue… has anyone managed toi concert to the E model yet? please!!!

I also bought the c-Version of the camera as the e-Model is currently not available in Europe and thought about the concerns that are mentioned in this thread.

I did only plug the camera into my computer running Windows 10. I did not install any drivers. The driver Windows uses is a Microsoft certified driver.

Is there after all the possibility that someone is spying on us by a compromised firmware in the camera? The camera itself only offers a video and audio stream thru USB, the rest is taken care of by the driver and application, right?

Anmerkung 2020-04-22 144914

So guys I feel your pain… Just spent the last 2 hours trying to figure this out. google obsproject
Download this open it and on the main screen where it says sources select your c930c, It may not provide all the function you need Im not too tech savyy but I bet If you got to know how OBS works you guys can figure it out… Let me know if this helps and also If people are clever using OBS please give me some tips.

i’m curious if anyone figures this out too!

Same thing for me here. Bought the 930c and it has Chinese characters. I also have the 920. Logitech Capture works with the 920 and doesn’t recognize the 930c. Firmware tool doesn’t see it. Guess I’ll see if the 930e firmware update see’s it…

@stubbie
I tried it before. You can’t update using the c930e tool.

Anybody has problem of C930c intermittent stop of VDO function

please give me suggestion

I use Windows10 and Camera setting all version but not work.

Anyone have any luck? I have been trying to figure out how the change the firmware for a couple weeks now…

I’ve also purchased the device from a big Chinese vendor who were actually advertising it as the C930E. I digress…

Been looking at this issue, and I think the only real difference between these devices will be the VID and PID used to identify it.

Both devices have the following VID: 0x046D

The PID however is different. The non Chinese version is: 0x0843
The Chinese version is 0x0891

I have a feeling that if we used something like virtualbox to spin up with W10 VM and alter the VID/PID details being presented to the OS, you might have a chance at updating the firmware and flashing it back to the E (European?) version. I can’t think of any other way to do this.

Hi,

For whats its worth… i have also got the 930c and ended up doing a search-n-replace in regedit to change the name of it.
I have not tried to move it to another USB port yet, but so far by changing: 罗技高清网络摄像机 C930c -> Logitech C930c everywhere i could find it now makes the chinese letters go away in the windows user interface.

I know its not a perfect solution - but at least things start looking normal.

It even looks ok in device manager (also after reboot :D)
image

1 Like

Not exactly sure how I would go about doing that. There doesn’t seem to be an option to add a webcam in Hyper-V. I’m guessing I will need something else.

I believe the E stands for Enterprise.