***FIXED***Linux X570 no reboot

Hello all, yes a nooob incoming…lol

…but have been freelancing around linux for a while, AMD Opteron 180 still kicking.

I finally got back to AMD thinking all should be stable etc…

New system works flawlessly, when operational that is, it just will not reboot.

Have tried multiple bios, kernels, ram configs, drive cofigs, complete system rebuilds. Doesn’t matter vanilla Arch, Debian stable, or distro, all installs will boot right in with first boot, run for weeks, but if a reboot is needed, all configs will go thru grub and back to (not) loading system, just hangs. Sometimes after 40-50 reboots it will finally boot, but usually a complete re-install is the fast solution, yes os is on seperate drive so not losing anything but time to redo, that doesn’t cut it for a workstation. Did not install nvidia drivers, will get amd upgrade. Phoronix test suite and Endverous distro bench marking, stress, temps, etc, all perform with stock bios settings and xmp profile (w/128g 3600 only using 64 though), haven’t changed anything in bios except xmp on/off, would like to overclock and get some work done.

Instead of listing all componemts, I put it all on a pcpartpicker page
pcpartpicker dot com/list/Tk8QMv

Thanks in advance,
zzjudgez

how are you rebooting? That sounds very strange.

We need more detail about the failed boot to diagnose.

I know that this is annoying, as you can’t really copy/paste at that point. The best thing might be to point a camera at your screen and post a video of the whole failed boot process

1 Like

Hello, thanks for replies, sorry for long wait, cardiac rehab issues.

“how are you rebooting? That sounds very strange.”

  1. click start, click Power/Session, click Restart
  2. terminal, [[email protected] ~]$ reboot
  3. terminal, [[email protected] ~]$ shutdown -r …preferred, for those who don’t know this, simply shuts system down and restarts one minute later.

Reboot is not the issue, it is after grub hands off. System reboots, goes to grub, select os/fallback, goes to next screen and stops.

When system is fresh build, install os and boots right in no issues, 1/all drives, any bios or kernel tried, will run perfectly fine.

System is currently completely disassembled, I am starting from ground zero one more time, even though I don’t think it will be a different outcome. I’ve been doing linux builds for a long time and this issue definetly mind boggling. Glad this is my personal build though.

I’ll grab a fresh grub.cfg and logs and post them if need be. I can use one of my websites and open access to public, instead of using restrictions here.

I don’t have another AM4 board to check board/cpu issues. But if I get a client for a build, I can/will use it as a test station. I only do Linux, usually Arch or Debian.

System Specs: Asrock Phantom Gamiing X, Ryzen 3950x, GSkill Trident Z NEO 128GB (using 64), 3x Intel 665p 1TB nvme, 4x Crucial MX500 2TB ssd, Evga GTX 1080 (not using nvidia drivers) (will get another upgrade 4.0 nvme, and AMD graphics etc.)

Thank You,
zzjudgez

That might be your issue. Did you install the nVidia drivers or are you using Nouveau?

My hunch is that Nouveau is being used during installation and then after boot the Nouveau driver is being black listed, assuming that you have installed the NV proprietary driver and then you get noVideo.

"ssd, Evga GTX 1080 (not using nvidia drivers) (will "

hummmmm… I am using vanilla Arch and I know nvidia drivers are not installed and Nouveau comes default with kernel.

I just looked at the Endverous distro, and it had nvidia in packagelist. Only tried it because it has some nice test suite options already installed, instead of downloading it all myself for Arch.

I’m doing the rebuild tomarrow probably, leaving 1080 out, add it afterwards. If only I could get an AMD 6000 series card, on 3 wait lists.

zzjudgez

Issue was nothing above… FIXED

Thank you to everyone of the 125 views… could of done without all of the superior help no doubt.

zzjudgez

What was the issue and how did you fix it?

2 Likes

Sooorry… don’t come here often.

Short answer… new build… new parts… one drive apparently was used and had a gpt table on it… wiped disk… all good.

zzjudgez

1 Like