Firefox youtube screen tearing on Ubuntu 18.04 with Unity


I’ve been distro-hopping recently and have had a hell of a time nailing down a tear-free configuration. For a while, I was convinced that my issues were hardware related (I have an Nvidia gtx 1080 using proprietary drivers and two 4k monitors), but I think it may actually be an issue with Firefox and youtube specifically.

Using this video to test for screen tearing issues, I found that the same video works correctly on Chromium. I would prefer to use Firefox if possible, so I was wondering if anyone has had a similar issue and might know of a fix (most of the other posts I’ve found seem to be more related to Nvidia driver issues).

Strangely, I am also unable to install extensions for Chromium through the Google web store (it just gets stuck on “checking” after I press the button to “Add to Chrome”), so I am not sure that switching to Chromium would be a viable option for me any way…

Any help would be much appreciated!


your compositor/DE matters as much as the drivers in my experience, not sure about firefox specifically, but I don’t experience tearing in the KDE compositor or the most current compiz. no idea about unity, but since it’s a mutter plugin IIRC, this fix should work there too:

more info about compositors here:

you can also try

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

if it really is JUST firefox, you can try

about:support > and see what the compositing mode is under graphics, then set layers.acceleration.force-enabled in about:config

1 Like

Hey @tkoham, thanks for the reply.

AFAIK Unity uses Compiz for compositing, and I have played around with the “CompizConfigSettingManager” to no avail. However, in this case, I think the compositor may not be the issue since Chromium is able to play the video correctly without any tearing whatsoever…

unity uses an ubuntu fork of the project that’s stagnant as of 2012 IIRC, you want “reloaded”

Try the OTMC fix and pipeline fixes I posted above first

I currently have the “force full composition pipeline” setting in my xorg.conf. Not quite sure what you mean by “OTMC” fix? Is that the Gnome shell extension that you posted?

I’m currently looking at the about:config options now.

oops, typo. means off main thead composting (OMTC) – a feature supported via the layers.accel option if support reports basic compositing

I see.

Yeah, about:support is reporting “basic” for compositing. Interestingly, “layers.acceleration.disabled” is listed as modified and set to “true,” which is not a change that I ever made…

Edit: Oops, I had forgotten that I disabled hardware acceleration while trying to fix the tearing issue. That is was that setting was switched on.

I’ll try disabling that and enabling “layers.acceleration.force-enabled.” Is that the setting that corresponds to OMTC?

yep. enable forced, restart ff

then check that about:support reports “opengl”

Nice, looks like that did it. Thank you for your help!

glad to help