Fedora broken

Hello all,

I have an old Core i7 Haswell desktop I run Fedora 34 on. It has 3 HDD’s in it and I installed it with disk encryption in case it was stolen. All worked fine until yesterday morning when it refused to boot and informs me the crypto LUKS UUID is not found. systemctl informs me the partition is loaded, inactive, and dead. It also says dracut is the same, loaded, inactive and dead. It suggested I reinstall initramfs but I’ve not been able to do that yet.

Can anyone suggest anything to help please?

Thanks in advance.

Chroot in to your OS from a live USB and make sure that /etc/crypttab has the correct luks ID (you can view it from gparted on your disk) once the correct luks ID is saved in crypttab, run: “sudo dracut -f” to generate a new initramfs. Let me know your results so I can help


Hello there and thanks for your help so far. I’ve been able to determine the partition numbers, /dev/sda1, /dev/sdb1, etc but cannot mount the latter one as it’s encrypted. I’ve tried using cryptsetup luksOpen for this but it’s not recognised.

gparted should not need the partition to be mounted

if you want to try mounting it… you have to manually use cryptsetup to open it… and you can mount the opened volume

Thanks for the help. I suspect one of my HDDs is dead because the two smaller ones show up in lsblk when I boot into the Fedora live image and I’ve used cryptsetup to decrypt them with no problems.


I ended up buying a new HDD to replace my faulty one. I’ve gone back to OpenBSD instead of Fedora and am happy with it.

Thanks :slight_smile: