Return to Level1Techs.com

Fedora 31 wifi/display issue

I have this weird issue with Fedora 31 and thought you guys might be able to help. I use an old laptop with a disconnected display and usually use ssh and vnc do get the jobs I need done.
However, after upgrading to Fedora 31 I noticed that the notebook was suddenly unreachable, but restarting solved the issue.
At first, I thought it wasn’ properly connected to the power outlet (the battery is dead), but everything was fine. I then figured that the upgrade might have borked my energy saving settings (e.g. sleep mode) and had a look at that. There I noticed the toggle that said something like “allow wifi disconnect to save power” being enabled.
When I toggled the button the notebook became unresponsive and several power-button restarts didn’t solve the issue.

I have now connected the notebook to my TV via HDMI, but xrandr complains Can't open display. Both wifi adapter (I have two, the notebook’s one and a USB one. I do not need the notebook one) were disabled. One I disabled a long time ago, but I did not intentionally disable the other one.
I executed icfonfig <wifi-adapter> up which enabled the adapter, but it didn’t seem to connect to my WiFi…

Any ideas on how to get it working again?

Unless you’ve disabled it, Network Manager will be handling your WiFi connections.

Check out this link for some commands to try:

https://fedoraproject.org/wiki/Networking/CLI#Wifi

1 Like

Thanks for the answer and sorry for the rather late response. But fixing this issue would have involved some additional work concerning my network setup and I intended to do change something anyway, because I purchased a RPi4.

Anyway, I tried a few commands but to no avail:

  • nmcli radio wifi returns disabled

  • nmcli radio wifi on doesn’t change anything

  • nmcli device status returns unavailable for both wifi cards

  • ifconfig wlp0s18u1u1 up returns SIOCSIFFLAGS: Operation not possible due to RF-kill, so I executed sudo rfkill list which indeed showed that both wifi cards were soft-blocked. sudo rfkill unblock wifi works in this case, but nmcli device statusstill returnsunavailable` for both wifi cards.

No ideas?
Because I start to wonder if it wouldn’t be faster to just reinstall the OS, even though I’d prefer to fix this problem in order to learn from it…

I’ve had the Intel wifi adapter get locked “off” in laptops a few times, pretty annoying glitch.

Usually this works for me:

  1. Go to the bios, setting the wifi to disabled, save and exit
  2. Disconnect power and remove battery, wait 60 sec
  3. Restore power and battery, boot back to bios
  4. Enable wifi, save and boot into OS
1 Like

Thanks. The problem with this approach is that HDMI does only show a screen at the OS level and currently I have a difficult time entering the BIOS (I don’t have a usable screen for this laptop anymore, part of the reason why I got it from a friend).
Maybe I could find a usable display, but I’ll have to look around.

Anyway, the problem started when I toggled the Wi-Fi button below.
image

Edit: Also, thanks for your time. It’s appreciated :slight_smile:

Oh, well that’s making it difficult!

An external USB 11n or 11ac adapter would be the cheap and easy fix, compared to replacing a built in display.

1 Like

I have an external USB WiFi adapter connected, that’s why I have two WiFi cards (see above).

I also have a different WiFi adapter I could try if that makes a difference. All of them are supported by the Linux Kernel, I made sure of that when I purchased them and I’ve also tested an verified it. (I.a. on this very notebook^^).

I have tried a few things with the notebook again and discovered the following:

  • After the boot, I have to execute sudo rfkill unblock wifi

  • Afterwards, I need to activate it via sudo ifconfig <wifi> up

  • Now, sudo iwlist <wifi> scan shows my SSID again. (nmcli dev wifi list is empty though…

  • nmcli connection up id <SSID> returns Error: Connection activation failed: No suitable device found for this connection (device <wifi> not available because device is not available)

Any additional input @gordonthree?

Edit: This stackexchange question describes the same problem, but (re)starting wpa supplicant doesn’t do anything for me.

The list command just prints out the results of the last scan, which is a different command, or using the --rescan option

ARGUMENTS := [list [ifname <ifname>] [bssid <BSSID>] [--rescan yes|no|auto]]

List available Wi-Fi access points. The 'ifname' and 'bssid' options can be
used to list APs for a particular interface, or with a specific BSSID. The
--rescan flag tells whether a new Wi-Fi scan should be triggered.

tried this one?

nmcli dev wifi connect <SSID> [password] 

per the docs:
ARGUMENTS := connect <(B)SSID> [password <password>] [wep-key-type key|phrase] [ifname <ifname>]
                     [bssid <BSSID>] [name <name>] [private yes|no] [hidden yes|no]

Connect to a Wi-Fi network specified by SSID or BSSID. The command finds a
matching connection or creates one and then activates it on a device. This
is a command-line counterpart of clicking an SSID in a GUI client. If a
connection for the network already exists, it is possible to bring up the
existing profile as follows: nmcli con up id <name>. Note that only open,
WEP and WPA-PSK networks are supported if no previous connection exists.
It is also assumed that IP configuration is obtained via DHCP.
1 Like

This returns Error: No network with SSID '<wifi SSID>' found.

Thanks for all your help, but today I installed Manjaro because I had no idea on how to fix this issue.