Return to Level1Techs.com

Fedora 31, dual monitors (DELL 3415Wb w/ASUS ROG Swift PG279Q 27) do not work with XFCE4

Hi all,

I am having lots of issue with configuring dual monitors on Fedora 31 (5.5.9-200.fc31.x86_64) running XFCE4. This is a relatively fresh install. I started with the ASUS ROG Swift PG279Q 27 (https://www.amazon.com/gp/product/B017EVR2VM/ref=ppx_yo_dt_b_search_asin_title?ie=UTF8&psc=1) and wanted to added the DELL 3415w (https://www.dell.com/en-us/shop/accessories/apd/210-adtr?gacd=9694607-1046-5763017-0-0&dgc=st&gclid=CKKgkMfIrOgCFZrBswodMxoPSQ&gclsrc=ds)

Here is the problem. I am able to add the DELL monitor without an issue when I am logged into XFCE. However, if I reboot the system the monitors never come back in that they both display no image (just a black screen) and the DELL monitor goes into some sort of sleep state. While I am trying to run both monitors via DP, I do get the same results even if the DELL to HDMI. So, this results in me not even being able to get to a command prompt when both monitors are connected. Strangly the monitor seems to work if I hook it to another GPU. Same system, same install.

The monitors do work individually but not together. I tried a monitor of a different model to replace the DEL and it worked right away. Hence, I suspect this issue may have something to do with DP or the DELL monitor itself. It can’t be the port on the GPU because I tried them all with Windows and they work. Is there something that I am doing wrong? I was under the impression that XFCE configures this automatically. Is there any way for me to make the configurations manually? How can I get the monitor to work on 1 GPU?

1 Like

Looks like installing the nvidia proprietary drivers fixes most things (https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/) and allows me to generate the xorg.conf file. The nvidia-settings GUI also helps but it took me some time to generate the below file which seems to allow for dual monitors to run on one card

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 440.64

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.64

Section "ServerLayout"

# Removed Option "Xinerama" "0"
# Removed Option "Xinerama" "1"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "DELL U3415W"
    HorizSync       30.0 - 89.0
    VertRefresh     48.0 - 85.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "Ancor Communications Inc ROG PG279Q"
    HorizSync       34.0 - 222.0
    VertRefresh     30.0 - 144.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 980 Ti"
    BusID          "PCI:3:0:0"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 980 Ti"
    BusID          "PCI:3:0:0"
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0"
# Removed Option "metamodes" "3440x1440_60 +0+0"
# Removed Option "metamodes" "3440x1440_60 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "DP-4.8: nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}, DP-0: nvidia-auto-select +3440+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}; DP-4.8: 3440x1440_50 +0+0, DP-0: nvidia-auto-select +3440+0; DP-4.8: 2560x1440 +0+0, DP-0: nvidia-auto-select +2560+0; DP-4.8: 2560x1080 +0+0, DP-0: nvidia-auto-select +2560+0; DP-4.8: 1920x1080 +0+0, DP-0: nvidia-auto-select +1920+0; DP-4.8: 1920x1080_60_0 +0+0, DP-0: nvidia-auto-select +1920+0; DP-4.8: 1920x1080_60_1 +0+0, DP-0: nvidia-auto-select +1920+0; DP-4.8: 1920x1080_50 +0+0, DP-0: nvidia-auto-select +1920+0; DP-4.8: 1720x1440 +0+0, DP-0: nvidia-auto-select +1720+0; DP-4.8: 1600x1200 +0+0, DP-0: nvidia-auto-select +1600+0; DP-4.8: 1280x1024 +0+0, DP-0: nvidia-auto-select +1280+0; DP-4.8: 1280x1024_60 +0+0, DP-0: nvidia-auto-select +1280+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0 {AllowGSYNC=Off}"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "metamodes" "2560x1440_144 +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On, AllowGSYNC=Off}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
1 Like

Out of curiosity, which repo are you using to get the nvidia driver ? negativo17 , rpmfusion , or the binary like in if not true then false

I am currently on Fedora 31: Linux LS0001 5.5.10-200.fc31.x86_64 #1 SMP Wed Mar 18 14:21:38 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

and how did you get the nvidia driver?

You can search for “nvidia driver download” and you should be able to get to the following page (https://www.nvidia.com/Download/index.aspx?lang=en-us) which will allow you to select your GPU model and Linux.

:laughing: I should have stated, but I do have an Nvidia card and typically recommend a repo to get it from.

I get my driver from a repo called Negativo17. This way I don’t have to install the driver the old fashion way. I just update through dnf.

I got to check that one one. I think I tried something similar in the past–rpmfusion maybe. That did not work out so I just keep going to the proprietary one.

So you just install the repo and dnf install nvidia? And the repo is updated with the latest drivers?

1 Like

Sorry misread this at work. Though it said distro.

Yup, he has a pretty good repo, Cuda-libs, Handbrake, FFMPEG, VLC, and other hardware accelerated tools.

I will say, if you have rpmfusion, and negativo17, you might need to blacklist the repo for certain packages like vlc. Since I want the negativo17 one, I simply add an exclude= line to the rpm repo.