Fedora 30 - breakage/things to know before upgrading

I’m planning to upgrade this evening at home (prior to the work machine) as a VMware Workstation + Vega user; am expecting to need to use/recompile the VMware modules as per normal, and will record what the upgrade breaks (for me) here.

Anyone else upgraded from 29 to 30 yet and have anything to share?


Thanks for being the guinea pig. I’ll be waiting a bit for repos to catch up… and breakage/success reports. :slight_smile:

Early benchmarks: https://www.phoronix.com/scan.php?page=article&item=fedora-30-potential&num=1


I upgraded both my laptop and main desktop from Fedora 29 to Fedora 30 yesterday.

So far I have noticed two issues, but they are related to specific pieces of software or features.


  1. The Dash To Dock Gnome add on extension is broken on both my laptop and desktop. After the upgrade all the favourites are missing from the Gnome dash. The Dash is empty with only the “Show All” button. Manually re-adding the favourites doesn’t work. So far the work around is just to disable the Dash To Dock extension and wait for a fix.

  2. The Plymouth graphical boot manager does not show keyboard feedback when entering your passphrase for encrypted LUKS volumes on boot. Keyboard input will be accepted so you can type your passphrase blindly and hit return (or hit ESC for text mode) and the boot process will continue but there is no feedback (dots as you type each character) and the boot progress bar is no longer shown.

The 2nd issue seems to be a known bug that crops up every now and then and it looks like it is affecting machines with older AMD GPUs. In my case I am using an AMD R9 390.

There’s a bug logged for the issue which goes back a couple of release and from what I can see it looks like it’s mostly with AMD GPUs although there are some reports where NVIDIA GPUs are in use.

Other than these the overall experience so far has been fine. Performance seems to have improved a lot too, in particular my laptop feels a snappier.


I wonder if that’s a bug or feature.

Definitely a bug, it would normally show a dot in the passphrase box for each character you type to give feedback and then when you hit enter you should see the boot progress bar. Now it just looks like the PC has hung and is not accepting keyboard input.

Here’s one of the bug #1490490 reports I found related to it.

That bug report predates Fedora 30, and I don’t have that issue on Fedora 29, so I guess it is a bug.

I was referring to the “no feedback on entering password” being a security feature for example when entering the root password in a terminal.

Yes, it’s been opened and closed a few times. I’ve had intermittent issues with Plymouth across the F28 and F29 release cycles, from issues with the LUKS passphrase entry box not showing up at all to the entire Plymouth boot screen not displaying (just a black screen). It’s usually after a major kernel update when there’s a new AMDGPU kernel driver.

Are you using an old AMD GPU? I’ve had to switch back to my R9 390 in the last couple of days because my RX 590 died. I didn’t experience any issues with the RX 590 and Plymouth but the R9 390 it seemed like there were issues every other update.

That is possible but based on the user experience of having absolutely no feedback when typing a very long LUKS passphrase I would doubt it was done deliberately for security. With the character dots you can at least tell that PC is accepting keyboard input and if you mistype you can see when you’ve backspaced to clear the input field.

I’ve also just noticed that when I use ESC for text mode, I just get a black screen anyway.

No, I’m using an Nvidia GT1030 with the proprietary drivers from negativo17.

Once the password is longer than the number of dots that fit into the input field, there isn’t really much useful feedback.

I don’t think I’ve tried ESC, but using the left/right arrow keys switches from the graphical boot screen to a text one with bootup messages, warnings, errors about modules, etc. I can enter the LUKS password from either screen.

1 Like

I think it’s AMDGPU related, there were one or two people who mentioned issues with NVIDIA but I am not sure they are the same issue. AMDGPU support for pre GCN 1.2 GPUs has been very sketchy.

That’s true, but when you’re 40 characters into your passphrase and you “fat finger” the keys it’s still handy to know when you’ve backspaced to the start again :smiley:

Thanks, I will give that a try the next time I reboot, otherwise I will just turn off the graphical boot until it’s fixed.

Just an update on this. The Dash to Dock add-on seems to be working again today on both my laptop and desktop. I am not sure why or how because the only updates I’ve had since the upgrade were MESA libraries :thinking:

You know that happens once every several boots. :smiley: It definitely doesn’t make for very impressive boot times! For prompts without feedback, if I make a mistake entering the password, I just sit on the backspace key for a good while.

1 Like

So, home PC.

(Asrock Taichi X470, Ryzen 2700X, Vega 64)

Ran upgrade from Gnome software updater.

Recompiled vmware-modules for recent kernels.

  • VMware works fine (workstation 15.03 at the moment)
  • haven’t noticed any issues to report thus far

something useful… :smiley:

1 Like

To my surprise, the repos seem ready for the Fedora 30 upgrade. At least no complaints of unavailable versions of packages for the new release. When going from 28 -> 29 it took weeks of waiting.

Being the compulsive updater (who else does sudo dnf update multiple times a day?), it’s hard to resist an available update… The 5GB of update packages are already downloaded, and I’m a sudo dnf system-upgrade reboot away.

See you on the other side!


Actually, it worked now (the day after). So it was a one time boot failure thing. Witch is somewhat good I guess.
I’ll leave the ‘story’ though.

My install either broke with the upgrade or it was a onetime thing. I did upgrade yesterday and when it was done and rebooted, it sat at the fedora logo for ‘wow this is a long time im gonna go sleep’. When I got up it still was showing me the fedora logo. Now im about to get home so I now gotta figure out if I can fix it or wipe it. I wouldn’t be opposed to reinstalling it, but I accidently placed my windows 10 bootloader on the linux ssd. So if i reinstall linux I gotta fix windows (probably). Otherwise I would have done a clean install right away.

My system has a 2700x and a gtx1070. Might be an nvidia thing. Not even a vaige idea though.

1 Like

One thing that broke appears to be the docker repository. But ONLY the repository. Docker still works from before the install, but when you uninstall it you then gotta install it with the rpm. Also did the upgrade now on my notebook. Same thing. Docker works. But repository is dead.

Strange thing they advertise ‘docker integration’ on their website more so than anything else.
But frankly I don’t really get what they mean with ‘docker integration’ anyways. Makes you think something is different, but I still had to install docker as I would with literally any other distro under the sun and then use it the same way. That’s perfectly fine. But what exactly did they integrate into what is the part I don’t quite get.

Are all the gnome extensions working? (Specifically dash to panel and shelltile)

Also how are the nvidia drivers with the RTX 2070?

Dash to dock is working. When I initially did the upgrade it wasn’t working correctly for me. All the favourites icons were not displaying and when I tried to re-add them it said they were already in the dock.

I disabled the extension hoping there would be an update in a couple of days but it started working again a day later. Something changed but I am not sure what, maybe just disabling the extension between reboots.

1 Like

Ok, the upgrade to Fedora 30 was really smooth. I noticed a few small issues, mostly with certain packages and repos, not Fedora itself.

The situation with third party repositories is interesting: they didn’t block the upgrade, but they aren’t necessarily ready for Fedora 30 yet. Note that the negativo17 repo for nvidia drivers is ready and is working great.

The following is a list of several small issues I encountered after the upgrade and one hugely positive change.

Let’s begin:

  • glances was downgraded to version 2.11.1… no idea why

Involving the MATE desktop environment:

  • The volume icon disappeared from the notification area and the package mate-volume-control-applet is no longer available. Solution is simply to right click on the panel and add the volume control item. No change in functionality.
  • Windows cannot be resized by dragging window edges with some themes that have borderless windows. This seems to be a bug or design problem with MATE 1.22. The solution is to use a different theme, or modify the theme’s css file to add at least a 1 pixel border. Simple. I took the latter approach for now.

Very minor aesthetic complaint:

  • The new wavy background image for Fedora 30 on the login screen creates the illusion that the login box’s edges are not straight. Yes, I’m nitpicking. I just changed it back to the background image from Fedora 29 that I liked better.
Third-party packages and repositories:
Failed to synchronize cache for repo 'docker-ce-stable'  
Failed to synchronize cache for repo 'Dropbox'
Ignoring repositories: docker-ce-stable, Dropbox
  • Dropbox is functioning, but the applet icon’s right click menu is stuck on “Connecting” and never gets to reporting the storage used, recent files, etc. Other menu entries like Preferences work. Syncing is fine. Noticed that their download site doesn’t yet have a directory for Fedora 30. Still working with Dropbox support on this issue.

  • Docker’s repository, which provides docker-ce, has a directory for Fedora 30, but right now only for the nightly and testing builds, not stable. Who knows how long that’ll take, as there was a similar issue at many previous Fedora releases. Fedora has a docker package in the native repositories but this is an old version, and seems not really recommended. More recently a new package called moby-engine is available in Fedora’s repo and seems identical to docker-ce but is slightly behind. So on Fedora 30, the choice is either to get (or stay on) the docker-ce-18.09.5-3.fc29.src.rpm Fedora 29 package from the docker-ce repo, or to go with the older moby-engine-18.06.3-2.ce.gitd7080c1.fc30.src.rpm version 18.06.3 package in Fedora’s repo. Choices, choices.

The big practical change:

*Browsing samba/Windows network shares in a GUI file manager now works!!!

I’ve been waiting a year for this! It might also affect finding network printers and scanners too.

Overall, the upgrade process was exceptionally problem-free. I didn’t even have nvidia driver problems or other kernel module issues. The upgrade itself took ~45 minutes to install/upgrade ~6200 packages. The upgrade time was about the same as for the upgrade to Fedora 29.

1 Like

My upgrade from 29 to 30 went flawlessly. I feel like I should note that I pretty much run stock Gnome 3 with very few extensions, however.

1 Like