Return to Level1Techs.com

Fedora 30 boot problems-"NVIDIA kernel module missing

#1

Hi all as title says, I go to the boot and it comes to “NVIDIA kernel module missing. Falling back to nouveau” and then it just never moved on from there.

I’m not the best with Linux still as I am learning alot but I really enjoy Fedora.

Any idea what I can do? I tried booting with kernel 5.1.16, 5.0.9, and in rescue w/ and w/o install USB plugged in.

Not sure what to try next.

1 Like

#2

Did you update the system recently, or did this happen out of the blue, or is this a fresh install?

0 Likes

#3

No updates. I installed this OS about 12 days ago now. I had seen a few prompts of dnfdragora having some updates but I never installed them.

0 Likes

#4

I should add that my only goal if this can’t be resolved is to save a Windows VM as the research software I use for work is installed there and Everytime I do a fresh install I have to go through a huge hassle of calling the developer and have them deactivate the previous install and activate the new one…

Next time I’m going to save snapshot to NAS

0 Likes

#5

Okay, first thing’s first, did you install akmod or dkms version of nvidia?

If it’s dkms, give me the output of:

dkms status
uname -a

0 Likes

#6

Your kernel may be too new for the driver, or your GCC versions are mismatched.

Try to install the driver with --no-cc-version-check. If that doesn’t work, the kernel is too new for the driver.

0 Likes

#7

Regarding that recovery:
All you need is to boot up in text mode or do a system rescue from install.
At worst you can always use Live and mount the drives.

Regarding the driver:
I do recommend using this repo as they are keeping up with binary drivers for a long time:
https://rpmfusion.org/Howto/NVIDIA#Current_GeForce.2FQuadro.2FTesla

0 Likes

#8

Ok, sorry for delay, had a long week working in the field and also have a kitchen remodel going right now…

When I get to the screen to select the version on Linux(kernel) hitting “a” doesn’t do anything but I have “e” and “c”.

“C” gets me into grub but --no-cc-version-check and dkms line both come back as “can’t find command”.

Am I missing something here?

0 Likes

#9

--no-cc-version-check is a argument for the Nvidia installer. Wipe the drivers and re-install with that argument.

0 Likes

#10

I got tired of trying different things so I just did a fresh install. Going to make sure to setup timeshift and also save my VM snapshot to my NAS.

0 Likes

#11

Hi All,

So, I have Fedora 30 reinstalled now and trying to get my Windows work VM up and running but seems that I am having an issues.

The OS is installed and working. However, the software that I am needing for work isn’t wanting to install. I want to make sure that this is a Windows issue and not a problem with my VM configuration.

When I try to install the program for work(the one that I mentioned earlier that is highly controlled by the developer) I get the following:

Error in GetDbinfo due to 53
Could not load file or assembly ‘ADODB, Version=7.0.3300.0,
Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a’ or one of it’s dependencies. The system cannot fine the file specified.

-I clock OK

“Unable to connect to licensed database”

Any ideas?

Would really like to get this up and running soon so I can get some computer work done this week.

Thanks,
-B

0 Likes

#12

quick update.

For the heck of it, I also just created a Win10 VM in Gnome Boxes and I got the same result.

0 Likes

#13

Test Mode. That’s pretty much how you bypass stupid stuff like this.

Altium Designer is one such thing that needs Test Mode to bypass stupid crap like this.

0 Likes

#14

how do I enable a Test Mode? This is new to me, i have had this program run many times on a Windows VM and never had to do this before

0 Likes

#15

New day new problem…

So last install I must have done something incorrectly. I wanted to encrypt my data and my HDD is now split.

I ahve the current install which is only about 73GB in size and then I have the rest of my 480GB NVMe locked up. I know the password that I set when I did it but it won’t take it to unlock it…so I can’t delete it using the GUI at all.

Is there a command line that I can use to get around this? I just want to delete the entire partition and have the full SSD

0 Likes