Fedora 29 Unable to load the 'nvidia-drm' kernel module

Since solving the usb boot problem I have freshly installed Fedora 29. Now I am following this guide to install the Nvidia drivers:

https://www.if-not-true-then-false.com/2015/fedora-nvidia-guide/

I am at the step where it says to reboot to runlevel3 and launch the nvidia driver .run file. However, it throws me an error in the installation process: Unable to load the ‘nvidia-drm’ kernel module. The problem seems to relate to having secure boot on in the UEFI, but I turned this of and this problem still comes up.

What can I do to fix this issue?

I am trying to install this on a laptop (Sager N850HP6) with the following specs:

Intel Core i7-7700HQ
Intel HM175 chipset
NVIDIA GTX 1060 6GB GDDR5
16GB DDR4
1TB Samsung NVME drive

Nvidia’s DKMS builds require the GCC version installed to match the version the kernel was compiled with. Any mismatch will cause DKMS to fail.

If it successfully compiles, but cannot load the DKMS module, it’s cause your kernel is too new for the driver. You will need the latest beta driver, 410.xx, in order to use the driver on the latest kernel.

Thanks for the response. It says the Fedora kernel is 4.19. I tried installing the latest beta driver 415.13 but i still get the same error. Before that I tried installing 410.78.

Any reason not to use the nvidia repo provided by fedora?

I read that the proprietary drivers provide better performance for games.

Yeah, Fedora provide a nvidia repo (not open drivers). just enable it in gnome-software and install.

I installed the 'NVIDIA Linux Graphics Driver from rpmfusion.org via the software application. This also installed Graphics Drivers Control Panel. However, I can’t open this control panel, it doesn’t do anything when I press Launch. Did It install correctly? How can I find out if it installed anything for the graphics card?

So I started over and reinstalled Fedora 29 on my Samsung 1TB NVMe drive, and ran dnf update. Before running dnf update, upon boot I only saw Fedora (4.18.16-300 …) next to Fedora (0-rescue- …) and Windows Boot Manager (separate ssd). Now I additionally see Fedora (4.19.2-300 …) next to the other two.

Checking lspci in terminal I see I have an Intel HD 630 next to the Nvidia 1060. According to the guide I posted earlier this means my laptop uses Nvidia Optimus technology and that I should use another guide if I cant turn the Intel chip off and I don’t have an option to turn it off in the laptop BIOS. This guide relates to the ‘Bumblebee project’ (https://docs.fedoraproject.org/en-US/quick-docs/bumblebee/index.html).

Should I use this guide to install Nvidia drivers? Or should I first use a different kernel?

I tried this guide, trying again with the driver version 410.78 with kernel 4.19.2-300 and I also get the same issue as mentioned in the opening post: https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-fedora-29-linux.

Is my hardware already outdated to use Linux as one would expect to be able to, like trying to play a game on Linux?

Optimus has notable issues with Linux. If everything you’re trying isn’t working, you need to use the negativio7 repository and build the driver from scratch, with dnf groupinstall "Development Tools" "Development Libraries" as the first step before installing from the repo, because you’re LITERALLY building the driver from scratch with this repo.

Don’t forget kernel-devel too.

As I suspected, GCC got updated in a recent pushed update, and even a minor version change can cause DKMS to fail to build. (Yup, even going from 8.2.1-4 to 8.2.1-5 can trigger a DKMS build failure if you stuck to an old kernel)

Your only recourse is to update the kernel, cause the GCC versions have to match EXACTLY.

If all else fails, downgrade your kernel and GCC to the one Fedora 29 launched with. (I hope it’s 4.18.x, if not you are SoL until Nvidia fixes it with a new driver)

Okay so I did another fresh install and without dnf update went straight to using the guide you provided @FurryJackman. I ran these commands:

  1. dnf groupinstall “Development Tools” “Development Libraries”

  2. dnf config-manager --add-repo=https://negativo17.org/repos/fedora-nvidia.repo

  3. dnf install install nvidia-driver nvidia-settings kernel-devel

  4. added RPM fusion free and nonfree repositories

  5. dnf install nvidia-driver kernel-devel akmod-nvidia

  6. dnf install nvidia-driver-libs.i686

  7. dnf install cuda nvidia-driver-cuda

  8. dnf install cuda-devel

I did not get errors running these commands. I rebooted the system but trying to open nvidia-settings via terminal I get:

ERROR: Unable to find display on any available system

Nothing happens either when I try to open it via Activities.

What should I do?

When checking nvidia-settings -v it says that version 410.73 is installed. Im on kernel 4.18.16-300.

kernel-devel will still grab the latest kernel instead of the one Fedora came with. You need to manually install that RPM from a RPM archive.

That’s the thing about dnf. If you don’t do an update, it still updates.

You literally need to do excludepkgs=kernel* to prevent kernel updates in your /etc/dnf/dnf.conf

I switched to Manjaro and after two days got it to work with Bumblebee, but the in-game performance (tested Dota 2 on Steam) is much lower than I experience on Windows 10. Might check out PRIME as an alternative to Bumblebee.

I was able to install the proprietary 410.73 nvidia driver on Manjaro on the 4.19 kernel, without the issues I get on Fedora. Alright, there is no dynamic switching etc, but this laptop is basically my desktop computer so I don’t mind that compromise.

Performance is also great. The framerate in Dota 2 is much better, over a 100 again at 1440p, while it was around 48 with Bumblebee, and gsync works too. I only added Lightdm, otherwise I was looking at a black screen when I rebooted after installing the proprietary driver.

In the near future I hope to set up a vm with hardware passthrough to play games not compatible with linux yet.

Thanks for the help on getting me this far.

When the Vulkan drivers get a rebase to the 41x.xx series of drivers, they’re worth checking out, cause DXVK has come a long way.