Fedora 27 fresh install, crackling audio

About to try and set up a independent profile for application. Its weird but for linux, for my tastes is not technical enough. I would have to look up and research how to change the audio core. I figure you are more savvy at it than I am. Try a different distro to see if the problem persists. I would swap out the equipment chain to see if something is causing it first . different keyboard / cables/headphones ect… different outputs.

1 Like

I’ve already verified the stack from speakers down to the port on the back of the motherboard. I’ll have to check out a different distro.

When it comes to audio, not really. I’ve never been that good with audio in general, let alone Linux. I’m more of a server/virtualization guy.

I’m going to post on /r/amd and probably talk to asrock support as well.


I just plugged the cable into the front-panel headphone out and it seems to be working just fine. I’ll play a bit of music to test, but it sounds wonderful.

Not sure if this rules out software or not, but I’ll burn an Ubuntu 17.10 liveusb and test a bit later.


I was thinking either a mb issue. Some sort of static/interference or basic level settings amped/ gain too high : needing to manually set base levels across all devices. gliche in the os/drivers. Something worthy of tracking down if I can reproduce it. :slight_smile:

1 Like

Didn’t expect that at all, plot thickens!

I tried plugging the Antlion ModMic into the ‘mic’ input at the back of the mobo (Sabertooth TUF X99), no signal in OBS. Front-panel connector, works but I have horrid noise floor. Compensating by adding -3dB of noise cancellation in OBS… (mine’s more an audio input issue here).

Can’t use my Focusrite Scarlet interface as the Antlion needs a 9-12vdc voltage vs the Scarlet providing 48vdc phantom power. I could solder up a solution, but then I’d need to grab another wall-wart and throw in some 12vdc regulation circuitry (which I’ve done for my home-made DIY lab power-supplies); just can’t be arsed to do so LOL.

Let us know on how you figure out the cause on your Taichi…

1 Like

I’m taking a break from sorting that out to just enjoy my Saturday, but I’ll definitely update as I progress.

1 Like

I have an Asrock X399 Taichi that uses the same ALC1220. I’m running ubuntu 16.04 and have crackling issues with my microphone. The output is good though.

1 Like

9-12v sounds high. an electret mic element usually only needs 3.5-5v. dc power from a pc mic socket is usually in that lower range

try a battery instead of mains power. very simple and no mains noise problems. you should probably add a capacitor to block dc power heading toward your interface, but the focusrite is likely to block it anyway

If the modmic can cope with a higher voltage than already supplied from pc you might get improved sound quality

1 Like

I am beginning to think it was something simple…

Just an update for anyone who’s encountering similar issues, I finally got around to RMAing the motherboard. Swapped it out, updated UEFI, booted up and I’ve got no problems now!

Apparently it was a motherboard defect. Thanks Newegg for the Advance RMA!

1 Like

Glad you got them to replace it!

Just FYI, I had the same issue with an Asrock X399 Taichi, just missed this thread because I was out of the country when you posted it. Curiously enough, also on the left channel. I ‘fixed’ it by remapping line out to another port using a fake firmware file.

1 Like

I guess that is kind of simple…:rofl: Rma the mb.

1 Like

I distro-hop too much for that to be a reasonable solution. I still have to send it back, but I wonder if there was a bad batch of one of the sound components.

You’ll be happy to hear that the RMA was as easy as calling them up and saying that the left audio channel is broken and asking for an advance RMA.

1 Like

Same here, two Asrock mobos with the same audio chipset, both with crackling on the left audio channel? That’s way too much of a coincidence imo.

I have no issues with my Taichi. Driver issues…yes.

Alright, update: I just tried applying the overclock and realized that I can’t get my 1700 to 3.7GHz (other board was happy at 3.8) at the same time as running my memory at it’s rated speed of 3200mhz.

Additionally, I’m unable to see one of my m.2 devices. I think I was sent a bad board. Reinstalling the original taichi and will report back if the deadlines I’m missing don’t kill me.

UEFI is updated.

UPDATE: Just got the motherboard installed. Looks like I’ve damaged my CPU. I’m beyond furious right now. I guess I’m going to Frys first thing tomorrow.

Damn man, hang in there. I’ve definitely been there.


Yeah, Amazon has agreed to replace the CPU, getting one delivered today, so I’ll see how that goes. I just don’t want to kill another CPU by putting it in a bad motherboard. (I also get nervous when using PGA CPUs after being on intel since LGA775)

1 Like

Of note:

There’s a similar issue to this except it’s caused by a still mysterious pulseaudio timing glitch on Linux.
Usually resolved by restarting the pulseaudio service, so it’s not always a Hardware defect.

Well, it happens every time without fail on the original board, never happened on the second board, for as long as I could get it to boot.

I’ll give that a try on the original board when I get the CPU in.

This is rapidly turning into a horror story :frowning:

1 Like