Fedora 27 fresh install, crackling audio

Hi all,

I just finished my Ryzen build, a bit late to the party, but got some good deals.

I’m encountering an issue. The left audio channel on the line-out is crackling. I’ve tested multiple audio devices (bookshelf speakers, headphones, portable speakers) and have verified that they all work properly when plugged into my phone.

It’s a clipping/crackling sound coming from only the left channel. I’m not really a pro when it comes to audio, so I was wondering if anyone knows of a solution to this issue.

PCPP hardware link: https://pcpartpicker.com/list/kbyKyf

Motherboard is AsRock Taichi x370, R7 1700, AMD RX 580, SeaSonic Focus 850.

been also having this issue when i have audio playing then something like discord opens on my browser.

thinking it might be because of different sample rates

1 Like

I ran into a similar issue, it is due to different sample rates, though how to fix it i didn’t bother, i just used an external DAC and that fixed the issue for me.


I’ve had similar issues on Fedora in the past with audio crackling and it was caused by speech-dispatcher and disabling it on the config file fixed it.


Nuke the audio drivers and reinstall… Realtek :frowning: Hit me today actually. Consider a fresh download as I noticed my original driver did not complete correctly. Should be able to uninstall with the download but have to reboot twice. One for the uninstall and one for the install. Don’t skip.

For windows 10 not sure about fedora ? I guess I could slap fedora in and play with it. :slight_smile:

@SgtAwesomesauce if you want the best DAC solution check these out - http://www.schiit.com/products/modi-2

I’m running multiple of these. For something cheaper, any ‘USB DAC’ off Amazon would still be better than any motherboard-direct solution.

On the Zenith Extreme - my frontpanel mic in has a huge amount of hiss, terrible base-noise. It’s silly how Asus etc. try to over engineer their ‘audio’ when any external DAC will always be sooooo much better.

OH Fyi - Fedora/Threadripper box, audio is perfect via the mentioned Modi-Multibit DAC as well as SPDIF straight off the Mobo > the Yamaha AVR.

1 Like

I am using a Fulla 2 with Fedora 27 and I am also getting audio artifacts. I have not been able to figure out what the issue is.

I’ve got speech dispatcher disabled. I’m wondering if it’s a software or hardware issue. I haven’t tested Windows. Might be worth booting up an old windows image I’ve got, for science.

If you have the time, booting from a Fedora 27 LiveCD and just playing a youtube video through the line-out will go miles to help me confirm if this is just a one-off issue on my system. No need to install it to disk as the problem was present during install.

I guess I’ll have to consider this. One of the selling points on the TaiChi was the (not great by DAC standards) above average audio solution on the board. I’m really hoping it’s not that.

I have the same problem, its not the hardware. The discord app is even worse, the discord webbrowser version cracks a little less.


From my exp. You are now going to hear more than your use to depending on who does the audio :slight_smile: The board sound is really that good and you will notice more weirdness in various audio recording and more Mistakes hidden in audio will leap out and smack you in the face. You will need to improve your music collection also :frowning: I will do a live boot and see how this translates to linux.

1 Like

Yes, but this is literally unbearable. the little “pop” noise that happens when you adjust the volume from the keyboard causes a ton of crackles.

All flac, all good.


mmm first time I have never had to screw with audio config. I will play with it a longer but not having issues. My audio is running through my gskills mechanical keyboard. It does have a little popping sound effect to the volume raising and lowering :slight_smile: It does have some crackling inbetween pops also.

Hmm, I wonder if I got a bad unit then.

I’ll have to install gasp windows

1 Like

? Your keyboard could have a issue or I could some kind of static buildup. Could be many things. My windows 10 freaked out yesterday and I had to nuke and reinstall drivers. Was actually a pretty good run for realtek. since feb. I will try a couple different output methods. The basic generic seems to work fine. Try s/pdif next

When I use the keyboard to change the OS volume, the problem happens with the os-generated sound. I’ve got a corsair keyboard with those nice volume wheel things. It changes system sound.

1 Like

Before I point out the obvious… changing sound effects and volume levels ? My sound efforts volume leve is at 0 and I still can hear it fine. mmm found a gliche at defualt…

It causes crackling when the volume is above 1/3. below 1/3 it’s extremely soft and I can’t understand voices on videos.

Haven’t tried changing sound effects because it seems to be happening with every source I play from, indicating it’s not a corrupt file.

Sources I’ve tried that have produced distortion/crackles/undesirable quality:

  • FLAC from my music library, played with Rhythmbox
  • youtube video played in firefox
  • vimeo video played in firefox
  • system sounds
  • music from spotify

About to try and set up a independent profile for application. Its weird but for linux, for my tastes is not technical enough. I would have to look up and research how to change the audio core. I figure you are more savvy at it than I am. Try a different distro to see if the problem persists. I would swap out the equipment chain to see if something is causing it first . different keyboard / cables/headphones ect… different outputs.

1 Like

I’ve already verified the stack from speakers down to the port on the back of the motherboard. I’ll have to check out a different distro.

When it comes to audio, not really. I’ve never been that good with audio in general, let alone Linux. I’m more of a server/virtualization guy.

I’m going to post on /r/amd and probably talk to asrock support as well.


I just plugged the cable into the front-panel headphone out and it seems to be working just fine. I’ll play a bit of music to test, but it sounds wonderful.

Not sure if this rules out software or not, but I’ll burn an Ubuntu 17.10 liveusb and test a bit later.


I was thinking either a mb issue. Some sort of static/interference or basic level settings amped/ gain too high : needing to manually set base levels across all devices. gliche in the os/drivers. Something worthy of tracking down if I can reproduce it. :slight_smile:

1 Like