Faulty mobo?

Hi, for christmas i got a Gigabyte GA-78LMT-USB3. and an Ace 750W Black PSU. I put it all together and the ethernet port wont work. I got a 4 pin to 8 pin adapter for the mobo connector thing and it still doesn't work. Does anybody know why?

You probably need drivers.

I have updated the drivers and its still not working

did you format when you installed the new motherboard?

no... how do i do that?

do you have a windows disk?


can try and do it the quick way first, put in the cd and run the repair windows options. This will reinstall windows (backup any really important files first). After this you will have to reinstall all the drivers again.

I would suggest googling guides if your unsure of what to do, theres loads around that can show you how to do it in an easy way.

i might just leave it... at the moment i've got wireless which i hate but i don't get good internet even with wired. and if i did do it, would i lose everything off of my computer?

no, but back up your files to be safe

well the windows repair feature usually just replaces system files and leaves programes/personal files intact.

but back up important stuff just incase (eg: if you have thet report thats gunna make or break your career , back it up) :)

oh and if your wondering why we are advising this major action, its because we think theres a driver error/conflict. Your computer probably thinks its old motherboard is still inside it and is trying to use files designed to work with the older mother board and not this new one.

ok, thanks for all your help :) luckely I don't have a job or anything too major so not really anything to back up. I shall do it later on.