Fairly new 2 port L1 KVM stopped working

Thought I’d post here before bothering Wendell directly. I’ve been using the 2-port 10Gb L1 KVM since late last year, and it’s been working fine switching off between my Mac laptop and desktop machines.

I recently unplugged a few of the cables in order to move some things around, and when I plugged everything back in, it went into a state where the green usb-power indicator lights work, but the red port-selection lights do not. Pressing the selection button does nothing – no beep, no change to port behavior, and no red lights. It will sometimes pass one monitor through, though unreliably, and none of the USB ports work.

I’ve checked the power multiple times, tried every combination of cables, stripping it down to a simple 1-port keyboard & monitor setup, and building back up to both computers with monitor, keyboard & mouse. All to no avail.

Can anyone think of a way to reset the thing or otherwise kick it to a known good state? I’d prefer to avoid having to RMA it!

Thanks,
Joel

You could try another 12v power brick with it (center positive, at least 1.5 amps), in case something has happend with the power brick. The green lights come entirely from USB power so don’t assume it has a dc power brick. When you plug and unplug the barrel jack you should hear a click.

No click and the ac adapter seems ok? Then probably RMA. Might have been something like static discharge moving things around, or something like that.

Wendell

1 Like

Thanks, Wendell. I’ll find another brick somewhere and give that a shot. Pretty sure I have something around here…

@j15r did you try this and have luck? I am facing the exact same issuea similar issue.

Edit: Not exactly sorry, I get a beep when the power brick is plugged in but the input selection buttons do nothing… interested if the power brick replacement fixed it

Email me so I can setup an RMA. If it beeps it’s getting power.
Have you tried the keyboard shortcut to switch inputs?

Hi all, thanks for the response, and sorry for the slow follow-up. It took me ages to get around to finding another matching 12v power brick. Unfortunately, no dice. There is a slight click when power is connected with either transformer, but otherwise it remains completely dark – no monitor or USB passthrough, no LEDs lighted or briefly flickering, etc.

Should I just email you directly to RMA?

Thanks,
Joel

Yep yep can mail it in and I’ll fix you up

Wendell at level1techs.com

1 Like