[**FAILED**] service while booting

I saw some systemctl failed while booting, anyways its booted successfully. But i had a bad past :slight_smile: I broke many Linux for many times. After a few rebooting it will be unable to boot. How can i check it out and fix it ?

depends on the failure, can you find something related to it on your journalctl?

If i only get print same with boot screen. From journalctl i saw many problems;

username not in sudoers
username has no password (i have a password)
config loading, failed there no config (my config file about smt else i moved it in a directory)
and a few more.

What command should i use ?
I tried:
list-units --state=failure (return none)
list-unit-files (this one and the other listed returned some failures and type down in the top and more few)
list-units --all
list-units

you should try journalctl -r and then just scrolldown until you find the failed service. If you saw the message during boot, it should be there. journalctl -r | grep "fail" might help.

tyler@tylerdurden:~$ journalctl -r | grep “fail”
Hint: You are currently not seeing messages from other users and the system.
Users in groups ‘adm’, ‘systemd-journal’ can see all messages.
Pass -q to turn off this notice.
Oct 28 21:40:33 tylerdurden gpg-agent[990]: Assuan processing failed: Connection reset by peer
Oct 28 16:09:09 tylerdurden sudo[5622]: pam_unix(sudo:auth): conversation failed
Oct 27 20:14:44 tylerdurden polkit-agent-helper-1[8436]: pam_unix(polkit-1:auth): authentication failure; logname= uid=1000 euid=0 tty= ruser=tyler rhost= user=tyler
Oct 27 18:18:50 tylerdurden su[4809]: pam_unix(su:auth): authentication failure; logname= uid=1000 euid=0 tty=/dev/pts/0 ruser=tyler rhost= user=root

That was the output when i use grep “fail”
Also other errors i saw in simple -r use.
I dont remember the failure in boot.

can you re-run the same command but as sudo? i don’t think a user without sudo privileges can see module failure logs. Not sure though, but those logs you shared aren’t concerning at all, just normal usage logs.

Daemon might be a problem:

dbus-daemon[558]: [system] Activation via systemd failed for unit ‘rtkit-daemon.service’: Refusing activation, D-Bus is shutting down.

or Network Manager himself. But without -r i saw openvpn (not using anymore and system trys to open it) i removed the openvpn with commends:

sudo apt-get remove curl network-manager-openvpn network-manager-openvpn-gnome
sudo apt-get remove curl openvpn

I guess now its solved. I installed gpu and when rebooted it was really fast with a few and full [OK]'s :slight_smile:

Another questions:
envyctonrol
I installed this which is not working. But i tried to configure the Nvidia GPU over hybrid/nov… how can i uninstall it and remove the configuration ?

1 Like

could also try

journalctl -p 3 -xb

and again, as sudo might show more modules that have failed / need better configs

(as per systemd - How to see error message in journald - Unix & Linux Stack Exchange and it shows the expected errors on my system)

1 Like

What about removing envycontrol program ? Because its giving me a problem about GPU.

1 Like

are you on a laptop?

envy control seems to control switching the GPU from iGPU, to dGPU, is a quick search is about right

Just because it failed at one point, does not mean it’s completely dead; some systems fail to start, as other bits are not yet running, but later work fine.

I would generally be more inclined to get a system working, but if it is not running, then removing should not be a problem.

systemctl status envycontrol

if the unit has some reason of why it failed, it may give a clue of how to fix it in the small log below it.

if you are not on the sudu-ers list, you may not be permitted to add / remove software? except on the GUI perhaps/

No its desktop. I installed because the website adviced it. First the system didnt see my Nvidia. It was using system/cpu’s gpu. I dont know how to explain it. The cuda. First intel gpu before installing real one.

Is says envycontrol.service didnt found. I didnt add manually, but another time (not this system im using) i face the same issue. It was bad setup, (headless i guess) anyways its a clean one. From boot, the system himself add the user.

1 Like

sure, sounds like you should be able to remove it then.

not sure what was causing the [failed] messages then, as they are normally systemd unit errors, I thought

1 Like

sudo apt remove --purge *envycontrol will do the job ?

1 Like

Sure, yep, if it was installed with apt, then the same would remove it

1 Like

I guess i find the problems sources. GPU didnt installed correctly nor any network stuff.

1 Like

ooofff, that’s a pain itself, not being able to get updates and install apps…

1 Like

I mean im connected to the internet but “if/ip/iw/iwconfig/ipconfig” not any of commands is working. I broke linux for 10 times :slight_smile: then i guess well linux. not getting any payment from nobody and they are not developing. But in the forum somebody said, its your issue, know what u are doing and carefully build it. But even installing and figuring Nvidia is a huge freaking problem. So im extra carefull and such. But i also reconfigure the internet and such.

1 Like

Good skills keeping it running, and also for not being scared to roll up your sleeves and tinker with it to fix stuff.

good luck with it, and hope you get on a bit better with it in future.

how is the experience overalll?

mostly working, except occasional annoying bugs?

lack of apps, but the ones that work are okay?

1 Like

Its all good by now. Debian is easy actually. What about Fedora ? I love the it, its simple and fast. Also the driver is loaded and equipped its just not showing in the CLi. I guess all is okay

1 Like