Failed Laptop Battery?

Hello all,

I have a battery I installed about 4 months ago not reporting anything.

**Anyone know of a a way to clarify the /status Unknown? I don’t think this has anything to do with software. **

I will get another on order… But that’s $160 on batteries in the last four months.

Something must have failed on the charger/output circuit is my guess. As I am staying in a hotel I don’t have any tools with me, and I’d rather not poke around on lithium cells.

sudo tlp-stat
+++ Battery Status: BAT1
/sys/class/power_supply/BAT1/manufacturer = MSI
/sys/class/power_supply/BAT1/model_name = BIF0_9
/sys/class/power_supply/BAT1/cycle_count = (not supported)
/sys/class/power_supply/BAT1/charge_full_design = 5280 [mAh]
/sys/class/power_supply/BAT1/charge_full = 5024 [mAh]
/sys/class/power_supply/BAT1/charge_now = 0 [mAh]
/sys/class/power_supply/BAT1/current_now = 0 [mA]
/sys/class/power_supply/BAT1/status = Unknown

Charge = 0.0 [%]
Capacity = 95.2 [%]


As in your laptop has killed multiple batteries within 4 months? What happened to the original battery? Have you been buying third-party batteries or OEM/Genuine?

1 Like

I replaced the original battery which had started swelling. It was over two years old. I replaced it with a ZTHY battery. I could not find an OEM version for the system. The replacement battery only lasted 4 months for currently unknown reasons.

Original battery below.

1 Like

I’ve never had luck with third party batteries, unless from reputable companies (ex. OWC batteries). It’s possible your replacement battery was just hot garbage, or it’s possible that your laptops charging circuitry killed both batteries. It’s hard to tell, and I don’t personally know how I’d determine that, aside from buying another battery, but ensuring it’s OEM or from a reputable third party company.

I assume you checked EBay for OEM/Genuine batteries for your laptop?

Yeah, I will see what I can find. Won’t really know if its the battery or the charging circuit until I have another to try. Thanks for the help.

1 Like

So in regular systems using Texas instrument chips, you usually have one chargecontroller on the Board handling the main PSU input, the switching between PSU and Battery and then charging the battery.

The battery itself also contains a TI chip called a BMS, short for Battery Management System which is usually connected over i2c SMBus on the same bus as the chargecontroller.

The BMS handles things relevant for battery itself like voltage, capacity, charge level, etc. In some cases, the BMS can also physically switch the Pack off to prevent further discharge from the system.

Usually those chips do that permanently in case there is an issue with the pack as well ass going into an ERROR state.

I have no experience with the tlp-stat output but when you have the time an the option to dig around, i’d suggest the following in no particular order.

  • open the laptop and disconnect the battery and have a look that tlp-stat again.
    if it still displays the same, well, no idea. If it does not display anything, that could mean that it successfully grabbed those infos from the BMS over SMBus.
  • Check with a multi-meter what voltage you get on the battery terminals.
    If it is 0V or close to it, the BMS very likely Errored out and is at this point basically dead. Not unrecoverably dead, but i’ll leave it at that.
  • Check what the old bloated one reads.
  • Look for info on the Chargecontroller and what that one reports.
    Though since that machine still works on a PSU, i assume that one is partially good.

Those TI Chips are good chips but can also fail in weird way.
I for instance have two Razer Blade laptops where one Hates the Battery of the other and won’t work at all with that even though it is perfectly working in the other one, and they are the same model, so compatible. No idea what went wrong there.

1 Like

Thanks for the solid reply. This was really helpful. I was traveling and was not able to test the old battery, or the failed one.

I am again traveling, and had another battery pack fail. It was a different ‘brand’ if that means anything :wink:

From what I have gathered, the batteries are not the issue. I believe it is some failure on the charging circuit or the example you listed below.

The system appears to have no power from the battery. If AC is removed, the computer powers off imediatly. The LED on the front is blinking red - ‘indicating a failed battery’ according to the manual. However, I read this is common from non OEM batteries and the system functioned for a month without issue while blinking. I was unable to find an OEM battery as well.

I can look at the voltage level once I am home and report back, however I believe the BMS has failed or is failing. It may not be worth digging into. Without some very low level troubleshooting and, surface mount rework.

Take care.

I would hazard the guess that if you can measure any reasonable voltage on the batterypack connector, lets say 10V, it is most likely a dead charge-controller on the motherboard.
Not that i have enough experience to back that up or something.

In that case, it would indeed need a rework. Though it isn’t that hard to do and if you don’t want to do it yourself, you will very likely find someone close to you who can do it for you.
Talking phone / laptop repair shops here.

1 Like

Once I get a chance, I will look at the voltage on the packs. I can get by with AC only if needed. I am holding out for the GPU ordeal to settle down and might look at a new PC down the road.

I had a similar situation to this in a laptop I accidentally left out in my car in a discharged state in the cold.

This caused the BMS to trip out on low voltage.

I just so happened to have a lipo charger I could configure to charge each cell individually. They were down at 3.0-3.1. It didnt take much to wake the BMS out of its protection state.

I dont recommend you try this one at home unless you understand the risks involved. I knew the pack was OK because I knew why it had failed. If you dont know what happened to the pack you should tread carefully.


This sounds plausible. The laptop was not on a the charger and thus, discharged nearly all the way. I do not have a LiPo charger I could use currently. If I did I would get a metal bucket and some sand for good measure. Kinda unreal how unsafe these packs we all carry around actually are :wink:


1 Like

My experience with BMS is rather slim, but rather extensive with Lipo cells from RC hobby and i say something doesn’t really add up for me in your @Adubs case, except that it appears to have worked.

In my experience BMSs disconnect the battery from the system meaning you can measure 0V on its terminals, while the cells are still alive at a healthy “cutoff” voltage, with the BMS staying the only thing sipping power out of it, and that is not a lot so that can stay that way for a long time.
That is not a “low Voltage fault”, just an empty battery.

For Lipos the saying is about 3.0V though one has to be careful because idle voltage isn’t load voltage, and the voltage curve of modern cells isn’t linear.
So with 3.0V idle voltage, the cells are seriously empty, but i still think not empty enough to actually cause a fault.

For Li Ion the bar is even lower and in general, 2.5V is what i know as the bar for harmful deep discharge that can still be recovered from, but that will have cost some capacity at the minimum.

So, i’d expect an actual “Low Voltage Fault” to happen at below 3.0V for lipo and less for Li ion.
And i’d also expect such a fault to be non recoverable by charging the cells back up, because the Texas Instruments BMS i had to deal with in in the Macbook of a friend, could only be recovered by actively clearing the fault state over SMBus.
Makes sense to me… at least kind of.
In his case, it was a replacement battery that got damaged in shipping and a cell terminal broke off, making the cell read 0V. The fuckers set a different Password in the BMS, so i couldn’t clear the fault.

So, in my opinion, a battery in a laptop, should not Low Voltage Fault just from discharging to 0%.
Or rather: Does not Fault that way unless something else is seriously wrong and i think we established already that something is seriously wonky in this case.

In Adubs case, well, there are different BMSes around so who knows?
Nice that it worked!

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.