Return to Level1Techs.com

FacrCry 5 hold VRAM until crash

I found an issue in FarCry 5 where I had the AMD overlay open to check FPS. This game was kinda crash happy anyway and I thought it had to do my GPU OC but it’s not.

Watching the VRAM after it crashed because I thought temps or whatever got out of range, I noticed that VRAM kept “accumulating” until it was at 7.6GB over my 6GB card. This was aside from the System RAM showing 6.6GB in use separately. The original error was RADAR_PRELEAK_64.

I shut the game down and searched, found a Windows “solution” that said to make a registry key to shut off auto windows update, so I did. Rebooted and tried again, also setting the “resolution” down to 1.5=4GB VRAM. The game still “accumulated” VRAM but released barely enough to stay under the 6GB, like 5996MB-6095MB. System RAM went to 6.8GB and stayed. Occasionally the VRAM crept into the 7GB range but would go back down within 60 seconds or so.

So I tried playing BF4 to see if that game does it and no. It uses 3-4GB VRAM and 6.6GB System RAM, no other issues. Any ideas why or how that game “holds” onto VRAM , increasing it until it uses it up causing resources to basically run out?

Higher textures = Higher VRAM.
There are some details, but basically that’s it.

That’s a memory leak (bug in game probably).

Reduce textures in game to min and check your memory allocation.

That’s what I did. They call it “resolution”, it’s really the anti-aliasing from what I read. I took that down to 1.5 from 4 (max). Didn’t crash but still slowly filled the VRAM. It’s like it’s storing 40 frames at a time, then passing them onto the GPU. Goofy Dunia game engine I guess. I think NewDawn does the same thing but I need to look.

With the game doing that, no wonder the FPS drops at times. They say it’s a CPU bound game, does that mean it holds half the game in the VRAM, half in the System RAM? If so, why do they use an AMD/Ryzen splash screen? The game ran fine on my Intel/Nvidia rig.

No, it means that your GPU is fast enough that CPU is holding it back.

Because it was older hardware game was probably tested on it,

No. Anti-aliasing is effect that makes jagged edges smooth. Nothing to do with texture size.

Imo game has bug, and doesn’t run properly on new hardware. And I’m not even sure what that hardware is, because you didn’t say. Vague AMD/Ryzen doesn’t say much :wink: What models, CPU, GPU. Also what resolution do you play in?

1 Like

Sorry, thought my rig specs were in the response automatically as per the “rules”, lol.

AsRock X570 Phantom Gaming 4S, AMD Ryzen 5 3600X(tuned), TeamGroup Xtreeme Gaming DDR4 3733 @ 3600mhz CL16 (custom timings), Gigabyte Windforce RX 5600 XT Gaming OC (2 fan type Rev. 1, new BIOS to 14GBps VRAM), Seagate Compute 1TB SSD, Corsair H110i GTX AIO, Corsair RM1000 PSU, Sceptre 32" 1800R 1080p 185HZ monitor via DP

I play at 1080p “ultra” settings no HD textures and detuned the “resolution” as they call it. It’s a sliding scale from 1-4 and shows how much VRAM the game will use. At 4 it was supposed to use 5GB out of 6. I slid it to 1.5 and it shows 3GB will be used. It’s totally separate from the other video settings.

Sometimes it will play for hours, others less. Flying a chopper or driving can make it happen sooner. Running through the woods will as well. Probably is a texture bug. One would think the game would allow the GPU to just process the frames rapidly but it seems to be buffering them a lot.

Ah, I saw your other post with this rig, just didn’t noticed its you :wink:

Yeah, that resolution should be texture resolution, but you could also post this settings screen to be sure, because I don’t have this game.

And as for game. Sorry to break it to you but I googled it meantime looking for “Farcry 5 memory leak”, and its literally plagued with it.
Seems like you were just lucky on previous rig that it worked without problems. Because people who had this bug before you fixed it, just by changing driver version for their NVidia card.

So I’m afraid that there’s no “silver bullet”, because this specific problem can be resolved by patching the game by UbiSoft for new drivers. Or you can wait for next GPU driver update and hope it will work, or try some older drivers for GPU. But AMD is not really responsible for fixing bugged games.

Also, if you still have old GPU, you may switch to it for this one game, until UbiSoft patches this game.

You may try also to change from ultra to highest, in case game changes textures size in some other way. But this probably will at best allow you to play bit longer before memory runs out.

Because memory leak means pretty much what you described earlier. Game is allocating more and more memory, but at the same time it doesn’t mark properly memory it doesn’t need, hence it should be freed but it isn’t.

Well, i’m off to bed, its almost morning :wink: Good luck.

Edit: Eh, one more thing :slight_smile: You may ask people, who are playing this game on 5600xt (or any 5xxx probably) and don’t have problems, what version driver they use. This has some chance of success.

Thanks for looking into it. I figured it must be a game bug in the code. I think the dev’s are from Sweden or something. I would post a screen of the menu but there are tons of similar complaints. I didn’t go through them all because they all have basically no final solution but one. The game, the series was poorly designed for any hardware, lmao! No genuine fix like an older driver or even card. Makes me very leery about buying FarCry 6 for $60, if the problem keeps going into the future editions. A shame because the game is fun is a ridiculous way. The whole series is but all have a crash problem.

Maybe that’s what the dev’s wanted as an “extra challenge”, because I did finish the game and just playing the “+” content now, which is the game again post apocalyptic nuclear blast. However, the challenge is beat the game while it crashes at the most inopportune times, before an auto save point.

I bought an Ubisoft account for this game off Ebay because I wasn’t paying full price for the issues but it still cost me $22. It had 2 other games with it though but they suck. Assassins’ Creed (1st one) and Tom Clancy’s Splinter Cell (2013). The latter has playability issues like won’t switch to 1st person sometimes, ignores keystroke inputs randomly, etc. So I bought the “frustration pack” I guess. Previous issues were frame drop/laggy feel with the Intel/Nvidia 1080 GTX.

I put a ticket in with UbiSoft. Apparently this game runs off the “Cry” engine which powered the Crysis series, that hardly anyone could run at more than 3 FPS, lol. There’s an entire WiKi on that game engine and it’s 3 generations of games that all have issues listed nicely. It’s staggering, I had no idea that engine is responsible for more tears than pepper spray! Games like “Kingdom Come”, there’s plenty of complaints about that running slow with great hardware. Another case of “ridiculatom”.

Yeah, Ubi is know for putting out junk with only bs marketing behind it. I heard about it and I don’t even game much anymore (mostly Kerbals if I have time). Last Far Cry I played was 3 I think.

3 is fun until it crashes. I think the FarCry series overall is good the design is very poor. It’s surprising on Reddit there’s an entire “cult” following FarCry 5, right down to the guy who did the voice over for the “Father”. People seriously “worship” him like they think his persona is actual life. Little scary, but then there’s Qanon, Pizzagate, weird.